Update damage my install

0 votes
asked Jun 14 by Tofino (12 points)

When I do a clean install of X.plane11 it runs fine. Updating from v. 11 ruins my installation. The installer tells me, that permission to files is denied, and that there is an empty file, that I can not find anywhere,

Log files are here, the problem have been there at least the last month, where I have tried to find a solution. I am logged in as administrator and the installer is run as administrator. The problem may be in windows 10, but I could not find a solution.

Apparently no one else has the problem, on the Avsim and xplane.org forums nothing has been mentioned, therefore I will try here

 

1 Answer

0 votes
answered Jun 16 by ice_pdb (488 points)
Give X-plane folder permission for your account (group and your exact user) plus run installer as admin. All I can think about it. Where do you install the sim?
commented Jun 16 by Tofino (12 points)
I have tried all that, my folder is E:\X-Plane 11, on my second drive. I wonder why I can install a new X-PLANE 11 without problems, files are written to the same locations, and the new install does not complain and functions without problems.

The downloaded version, from Laminar not Steam, is v11 and runs fine, so the updates is not that important, but I like to have my programs up to date.

I am logged in as adminstrator and the update program is set to administrator in the compatibility setting. The user\sejr6\appdata\local folder is open for all users.

Will have to wait for the next update and try again, my bug report got the same advice as you kindly gives me, and on my pc that dose not do the trick.

Thanks for your answer.
commented Jun 16 by ice_pdb (488 points)
Mmmm weird. So you did give permission to "E:\X-Plane 11" for administrators group, your account, I'd add everyone too. what I don't get is why you mess with "user\sejr6\appdata\local" that is kinda system folder and windows manages it as it pleases. Did you try moving your Installer somewhere else? I run mine from desktop,checked as admin under the compatibility settings. Other thing that I can think of, is about Windows UAC settings, I totally disabled that feature.
commented Jun 16 by Tofino (12 points)

I have tried from the desktop, no luck. :-(

‚Äčthis message is why I have worked with that folder.

Thank you for your interest in my problem, it might be something win10 related, I have struggled for 2 weeks now, and will use the v. 11 and wait with 11.01.r2

During the beta phase I updated without problems.

 

 

commented Jun 16 by ice_pdb (488 points)
I would try one more thing. Creating a new  local admin user and trying installing with it. I also use Windows 10 and  never got that issue. May something is wrong with your present account. Also disable antivirus (just in case)

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

...