Cannot calibrate Hostas X joystick because it is not recognized by computer.

0 votes
asked Aug 7 by dickandanita (14 points)
Had to have a new hard drive installed - OS is windows 7.  I cannot add Thrustmaster Hotas X stick and throttle to the list of recognized sticks.  No problem until the hard drive change.

1 Answer

0 votes
answered Aug 7 by amelingu (1,743 points)
Hello,

First of all, can you make sure you have the latest driver for your joystick?

Sometimes, it helps to just unplug and plug again the device.

Is your joystick recognised in Windows, in the config panel?

Then make sure you have the latest version of X-plane (I would recommend the current beta 11.05r1). For this, you just need to run the X-plane 11 installer and tick the appropriate box when going through the installation process.
The installer can be downloaded here :
http://www.x-plane.com/kb/digital-download-install/

If X-plane still does not recognise the Hotas, you can try and delete (or rename or move for backup) the entire X-plane 11\Output\Preferences folder.

Please tell us if this solves the problem.

Also, make sure every axis is calibrated.

Don't forget to check these 2 links, you might find further information :

http://www.x-plane.com/manuals/desktop/

http://www.x-plane.com/knowledgebase_category/troubleshooting/

All the best with that,

Guillaume

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

...