Can you help with crash from 0:00:00.000 E/PRF: Failed to restore custom screen resolution. Monitor 0 does not

+1 vote
asked Nov 16 by yeswedeliver (15 points)

Hello, and thanks in advance for the time in reading and helping me get this solved.

Essentially, I rebuilt a PC just to be able to run x-plane using reasonable settings. I bought an intel board, quad processor [2.6], 8gb ram, and  … a GeForce GT 730 with 4 gb memory.

I am all ready to buy the full game – but am holding my breath because I just can’t get the demo to run now. Xplane 10 runs with older drivers that were more stable w xplane according to forums at nvidia. I've also tried the very latest.

It crashes after loading –usually just before showing me the ‘setup’ window – it shows a sort of rainbow screen of the setup window and then disappears/crashes.

Here is what jumped out at me as I looked at the log and compared it to the working x10 log:

0:00:00.000 E/PRF: Failed to restore custom screen resolution. Monitor 0 does not appear to support a resolution of 0x49566995.

Fetching plugins for C:\X-Plane 11/Resources/plugins

0:00:22.260 W/ATC: Rewrote KAHN atc_ControllerRole_Del's freq: 13395 to 11800 for being in conflict!

I should mention that the large screen smart tv I am using would support most any resolution it wants to run in – and I have tried various settings – even 720 – even switched to vga … no difference.

I’ll try and add the full log – if I can’t attach it I’ll pate it.

Thanks again,

Jerry

 

1 Answer

0 votes
answered Nov 16 by CaileanNZ (367 points)
Hi Jerry,

Have you tried a different monitor? Like a dedicated monitor rather than a TV as a monitor, There shouldn't theoretically be a problem with using your TV as a monitor but I think it would be worth a try to test different hardware because of what your log says.

Cailean
commented Nov 16 by yeswedeliver (15 points)
No, I only tried switching to vga... I have a smaller LED, a bit older that will connect with DMHI - and an older small monitor that only accepts vga... I will try both to see what happens and will save the logs. Thanks very much for taking the time. It may be a day or so but I will report the result. Thanks again, jerry
commented Nov 16 by CaileanNZ (367 points)
Okay, Yeah that would be a good idea and also sure thing, I dont mind about waiting for reply because I work anyways.

Cailean
commented Nov 18 by yeswedeliver (15 points)

Well, I tried and tried. None of the monitors made a difference. I will post results just in case someone wants to look - in log names 'Emerson' is the 32 in. older flat screen w hdmi input. 50 in is Westinghouse smart rv - less than a year old. HP 17 is older flat screen monitor - flat screen but vga connection.

Log shows it is reporting back several unworkable formats - all if formatting is as simple as it seems - way larger than any monitor could provide. I put all settings to default - fooled around with aspect ratio, screen adjustments - again and again. old drivers new drivers... Ha - when all done - no xplane 10 runs in a little window!

I have prepared to overwrite the OS. I hate to as I have hours invested already in setup... but I am going to start clean. It makes no sense to use your [other peoples' time] if there is a quirk in the OS from changing so many settings over time. I seem to remember it may have even worked once about ten days ago.

So, I will reinstall windows 7 - let it complete windows update - I'll install board drivers - and then the sim - if it happens again with a fresh install - I'll come back and submit a bug report.

I will add that this line doesn't seem very positive either - do you recognize the reference:

0:00:22.260 W/ATC: Rewrote KAHN atc_ControllerRole_Del's freq: 13395 to 11800 for being in conflict!

I'll check back on that error and will report one way or the other if the new install solves the issue. I built this pc just for this purpose -but began using it for other purposes too and maybe something is quirky as a result... it is a frustrating issue...but apparently not the monitor.

Thanks again,

jerry

 

commented Nov 18 by CaileanNZ (367 points)
Oh bugger, Sorry to hear that man. I mean I wouldnt reinstall your OS until maybe someone else comes over and gives you their opinion because that could be far different to what you are going to do. Or they might find something in logs that I didnt see because I didnt look at the logs in much depth because I dont know what im looking for. Personally Id wait for a bit before you reinstall OS and start clean because you might not need to. Sorry its frustrating mate, I hate when these issues occur and its very very annoying. I have about the same story with both Forza Motorsport 7 and Horizon 3. I built my PC especially for those games only to find out I have to reset windows everytime I want to play it. Which as of the new windows update has made it so I cannot play it at all. Very annoying for a game thats built for windows OS you'd think it would work before they released but i guess not.

Gookluck with X Plane though mate, Hope you get it sorted soon so you can get in the air with the rest of us.

Cailean
commented Nov 19 by yeswedeliver (15 points)
Good advice; I'm sure your issue must have been just as frustrating, but as I see the work that went into it, the quality, and the price - I try to remind myself that patience is a virtue in the right circumstance. I blame my my nvidia card that I thought was 'the bomb' :) with 4gb of memory..but is junk. Even 'knock off' junk. Gt 730. I know the drivers are quirky with this game [and others] and it is not as powerful as it boasts - I think this game kills it. But that is just anecdotal stuff and my experience is very limited to just learning by need. What really pokes me is that not x plane 10 looks like its running in a window - but the game really just changed something in resolution so the desktop really is only about 25% of the screen size. Phew. I'm a guy that does like it to work, all of it, most every time - or I want to fix it. I hesitate only knowing I must replace the card to get the experience I desire anyway. I just can't justify spending that kind of money - anything like in hundred(s) for a used one is just out of sight. One day. Anyway, thanks for your good advice.
commented Nov 19 by CaileanNZ (367 points)
Yeah, I know where you are coming from. Hope things turn out well for you and you find a fix or someone else can help you find a fix.

Cailean

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

...