This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (12 points)
edited by
I just purchased X-Plane and have the same problem as others using UHD.  I have a Lenovo Y50-70 laptop with 4k monitor,16 GB ram,  and a second Dell U2715H 2560X1440 monitor I would like to run the program in full screen.  The display cuts off some of the instrument panel at full screen; however I can scroll the full view with the arrow keys.  Unfortunately, the biggest issue is not being able to control any of the planes motion with my mouse.   This is very frustrating as I already purchased the program and am unable to use it.  The mouse box only appear about one square inch, regardless of varying screen resolutions or text size, making it impossible to fly the plane.  I also have the same problem as previously described with the tiny dialogue boxes, which I can at least see well enough on the 4k monitor to adjust settings with a magnifying glass.  I tried changing the text size down to 100 as mentioned; however, the settings box became so small it's unusable.
Waiving the white flag.
commented by (12 points)
Bought the CH pedals and yoke.  Problem solved!  I probably should have done that in the first place, but wanted to demo the program first.  The Cherokee sim is very similar to my own, with the exception of stall characteristics, and the real plane feels more stable, but that's probably more related to inertial and real pressures on the yoke and rudder.

1 Answer

0 votes
answered by (332 points)

I think the problem with most stuff not scaling with 4K resolution is known to Laminar Research. I have the same problem, most menus are hard to read at 4K...

The interim solution - and highly recommended for serious flying anyway - is to get an USB joystick. They are really not expensive, and even a very simple one will enhance your flying experience immensely!

Lets hope Laminar adjusts to the advent of 4k resolution soon,

Good luck, Jan
commented by (12 points)
The yoke and rudders definitely were the solution!