+1 vote
asked by (16 points)
Hello Support!

I just purchased this morning after reading the awesome news that native VR support is finally arriving.  I'm so very excited to try it out.  I briefly gave it a go this morning but unfortunately it was unplayable.  The video was stuttering badly whether I was turning my head or looking straight ahead.  I tried lowering all of the graphic settings to the minimum but there was no improvement.  

The touch controllers seemed to work well, and I'm actually really looking forward to getting into X-Plane.  Looking forward to all the updates and any feedback.

AMD Ryzen 1700x w/16 gigs DDR4 2933 and an AMD RX480 video card with 8 gigs GDDR5.

Super excited about the upgrade guys!

Thanks!
commented by (16 points)
Oh - there is no stuttering in NON-VR version btw.  It looks smooth as silk.
commented by (15 points)
I can second the issue. Very smooth without VR. And smooth using FlyInside. But unusable with SteamVR on the same settings.
commented by (16 points)
@rothschild86  I followed the directions from the fellow below and the stuttering all but went away.  I was able to do a short flight in VR and it worked well.  The issue I have now is not one that can be solved by X-Plane I fear but is one that needs to be solved with future generations of VR HMDs.  The resolution is too low to actually read any of the gauges.  

I don't have them memorized as I'm a pretty new student pilot so it actually makes it quite difficult for me to operate.  I think I'll sit this round of VR flight sims out until HMDs catch up with the quality of X-Plane.
commented by (18 points)
I can relate to this issue. I tried removing preferences which hadn't worked.

2 Answers

0 votes
answered by (14 points)
For what it's worth, I have the same exact issue so you can likely rule out drivers since I have opposite hardware, using an Oculus Touch.

i7 4790k

GTX 1070

16 gigs of ram.

 

The stuttering seems to happen after about 1-3 minutes of flight time. Further, sometimes when I load in the outside appears to have a double image and looks awful. Requires a reload of the game to fix. However, my stuttering only occurred when looking around. Straight ahead, it was fine. It was a microstutter that wasn't super bad, but sort of ruins the experience compared how smooth it is when the flight first starts. I've also tried all sorts of graphical settings.  Not a bad first attempt at VR but it seems like there's some bugs that need working out.
commented by (16 points)
Hmm... my stuttering happens during look arounds too, but I don't hold my head completely still so I see it every time I move.  It actually makes me sick so I can't look at it for more than a few minutes.  I bought the game because of this update, thought it would be in a little better shape, but I'm sure they'll fix it.  I'll probably sit this release out and see how things are with the next update.
0 votes
answered by (14 points)
edited by

I've spent many hours trying to solve this problem, simply because I've experienced it at it's finest, silky smooth with no stutter at all, then BAM ! unplayable, for what I thought was no apparent reason, until now...

Try this, works 100 percent of the time for me. 

1. Uninstall or at least disable Oculus Tray Tool (it does nothing you can't achieve by other, easier means)

2.Browse to C:\Program Files\Oculus\Support\oculus-diagnostics and run the OculusDebugTool.exe (make a shortcut on your desktop)

3. Set your Pixel Display Override ( I use 1.5 and can see everything clearly), and set Asynchronous Spacewarp to DISABLED.

4. Fire up X-Plane and go into the Steam VR settings on the grey box that pops up at the bottom of your screen, in the Performance tab make sure the two bottom check boxes have ticks in them, close the settings window, close X Plane and manually close Steam VR.

5. Back into X-Plane, load your flight and when you are in your plane move your head back and forward rapidly, if you see stuttering keep reading !

6. Stay in the plane, and in the Oculus Debug Tool that's still running on your desktop, click on the Asynchronous Spacewarp tab, change from Disabled  to FORCE 45fps ASW ENABLED.

7. As soon as you make that change you might notice your graphics card not working as hard, back in the plane move your head about and you should be free from stutter.

The next time you want to run X Plane just start the Oculus debugging, disable ASW, start X Plane, get in a plane then Force Enable 45fps ASW, and you're good to go.

I've tried this with mostly planes that aren't certified to work in VR and it works perfectly for all of them, good luck and have fun, if it works for you please spread the word, it makes the difference between a rubbish experience and an outstanding one !

commented by (17 points)
I have the Beta 2 version and no where do I see steam version. I tried your fix but frame rates still at 12fps

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...