0 votes
asked by (12 points)
X-plane 10 Installer Linux won't open. If I attempt to open it with Deb Package Installer I get. Could  not open ' X-plane  10 Installer Linux'.   the package might be corrupted or you are  not allowed to open the file , Check the permissions of the file.

1 Answer

0 votes
answered by (18.4k points)

Please double check that you have the latest version available here and that it's the correct format (only the Linux installer comes in separate 32 & 64 bit versions).

commented by (12 points)
Yes I went all through that. None of the X-Plane 10 or 11 Installer Linux will open & run.

I had the program running on this computer on Mint 17.3. Now it won't even open when I run Min 17.3.
commented by (18.4k points)

You might try asking in this X-Plane.org forum specifically for Linux users. I don't use Linux and won't be of much help for any additional troubleshooting.

commented by (12 points)
I have the exact same problem.  I bought X plane 10 Linux  global 8 disc set. Ran fine on 17.3.  Installed a 2nd H.D. & loaded Mint 18.0         Now X plane 10 CD's won't run. Tried d/l X plane 11 demo from Laminar Research. Installer won't open & run. Also the Study Guide program ( Linux) have for my pvt. pilot license no longer runs on either H.D./OS.  Unable to get ANY help from any Linux user group etc. L.R. told me it's  a Linux problem. Linux chat site users keep trying to tell me it's a software problem. ( it can't be if it's happening w/ 2 separate programs!!)  It's been MONTHS  & I can't get any help anywhere.
commented by (18.4k points)

Our support for using X-Plane with Linux varies.

  • While X-Plane 11 will run on Linux, we don’t provide support for specific distributions; if you want to run on Linux, you will need to try X-Plane on your distribution to see if it is compatible. With that in mind, we have developers using Ubuntu 14.04 and 16.04 LTS successfully.
  • For Linux, we require the proprietary driver from AMD or NVIDIA to run X-Plane. You may be able to get X-Plane to run on the Mesa/Gallium driver with an Intel GPU, but this is unsupported.  We absolutely do not support the fully open source drivers for AMD and NVIDIA.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...