This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (12 points)
I am successfully running X-Plane 11.01 under Windows 10 with 32Gb ram,  a i770K 4.2 Ghz cpu and a Geforce GTX 1080ti 11GB overclocked graphics card  The 3 monitors (21:9, 34 inch 2560x1080) are identical and are set to "full screen" in a wrap around configuration (45 degrees fov left, center and right).   In some locations I easily get > 40 fps but in more demanding/detailed settings (e.g., NYC), I'm lucky to sustain 20 to 21 fps with less than maxed out, even mid range, settings.   Having read that X-plane is faster in 'windowed mode,' I hoped to try that option, but the choice is not available among those appearing in the graphic windows setting screen (there are only 3, not 4 ohoices), contrary to what is claimed and/or illustrated in some documents and videos explaining the graphic settings.  Any insights would be helpful.  Could the 'windowed" option not be available with multiple monitor setups? .

1 Answer

0 votes
answered by (5.3k points)

Hi leberp,

Have you tried going into your Win10 display settings?

Also have a look at this from X-Plane

Hope this helps.