This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (14 points)
The heading knobs are missing on all my planes, whether default or addons. I did not change any preferences, or install any new plugin or addon that can cause conflict. Xplane is up to date through Steam (I don´t know what version but the most recent one). I tried to delete added plugins and custom scenery but nothing seems to work, and searched the forums, but haven´t found an answer or any clue, any ideas? Thank you!
commented by (17 points)
Not just you. only some of my planes have heading knobs and many are missing both heading and localizer heading knobs. Trying to figure it out but so far no luck

2 Answers

0 votes
answered by (19.3k points)
Make sure your graphics card is up to date. It seems pretty odd that just one type of knob would suddenly stop showing up. I have never seen this though, or heard about it from other users, so it is probably specific to your computer.
commented by (14 points)
Thank you for your answer but I don’t think it’s a graphics card drivers issue, in fact I updated the drivers to try to solve this. Anyway, I decided to reinstall Xplane again, and all the addons and plugins I had and everything seems okay now, the heading knob is back. Having said that, if anyone could give some light about this issue I would really appreciate it, just in case it happens again with the new installation.
commented by (10 points)
I have the same problem, missing heading knob, but don't want to go back to an earlier version, any other solution?
commented by (26 points)
with so many preferences saved in preference files, this should be the first place to look whenever a "bug" shows up or disappears.
0 votes
answered by (26 points)
This problem seems to happen whenever an update to X-Plane occurs.  I am on the newest beta version and have found that if I don't save my preferences folder (XPlane\Output\preferences) BEFORE doing the update then some things magically disappear or change or whatever from my previous settings.  I USUALLY copy the preferences folder to my desktop and then after updating XPlane and before running the program, I copy the preferences back overwriting whatever the update built.

Specifically, for the heading knob, I found in the XPlane.prf file you will find the setting:

_hdg_hold_mag[0] 0.000000
_hdg_hold_mag[1] 0.000000

If the setting is set to "nan" on both lines where the 0.0000000 is, you're hdg bug is goners.  Just delete the "nan" and save or put in the zeros and save and rerun Xplane.  Fixed it for me.  Not sure why or how the option "nan" is added, XPlane folks should fix that.  

Happy flying!
commented by (14 points)
Thank you! I take note for the next update.
commented by (24 points)
Thank you for this, solved the problem for me.
commented by (10 points)
Agradeço aos senhores pela ajuda, estava com esse problema e consegui resolver. Muito obrigado a todos.