0 votes
asked by (12 points)

Hi all,

I am looking for some help with some issues that have arisen within my version of X-Plane 10 and I have tried everything I can think of, both in X-Plane itself and generally in my Mac settings to resolve the problem with no success. 

Firstly, the cursor problem

So, this problem appeared seemingly out of nowhere. I opened X-Plane as normal and the finger pointer icon appeared with a white box behind it and the rotate icons appear with a white square outline (See Pictures). I have explored rendering options within X-Plane and can't find anything untoward there. I have also looked at system prefs of my mac, mainly in accessibility in case I inadvertently switched something on. No success here either. I've browsed the forums and can't find anything similar, hence the new topic. Hopefully someone here has seen this before and/or can advise on how to solve it.

Secondly, the scenery problem

I opened X-Plane as normal and none of my custom scenery will load! I haven't changed anything and haven't tried to add or remove anything recently.

It's probably worth mentioning that these problems both appeared at the same time and after a while of not using X-Plane and before I opened it for the first time after the break, I updated to the latest version, v10.51 I believe.

I run X-Plane on: 

late 2013 21.5" iMac

Processor: 2.7GHz Intel Core i5

Memory: 8GB

Software Version: 10.13.3 High Sierra

Graphics: Intel Iris Pro 1536MB

I have attached the most recent log.txt file and screenshots of the cursor problem.

Hope someone can help and that i have given enough information!

Pictures:http://questions.x-plane.com/?qa=blob&qa_blobid=15417045566827096568

http://questions.x-plane.com/?qa=blob&qa_blobid=13887014557203712490

Log.txt

http://questions.x-plane.com/?qa=blob&qa_blobid=15360198185872199341

Thanks in advance

Connor

commented by (12 points)
I should also say I have completely removed X-Plane and reinstalled it which did not solve the problem!

1 Answer

0 votes
answered by (3.5k points)
Hi,

About the cursor, have you seen this topic?
https://forums.x-plane.org/index.php?/forums/topic/130246-mac-high-sierra-the-white-box/

About the custom scenery, i have no idea.. could you attach the log.txt you get with your brand new install? Make sure the scenery you want to install is before "global airports" in alphabetic order and delete ../X-Plane 10/Custom Scenery/scenery packs.ini file before launching X-plane.

Maybe, try to move X-Plane 10 folder to your desktop...

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...