0 votes
asked by (14 points)

I am setting up a physical G1000 panel from Simkits/TRC, which doesn't explicitly support X-Plane. However, they have a piece of software that maps any interaction with the physical buttons & knobs to a keyboard command. Using this, I have a 1:1 mapping of buttons/knobs to keyboard shortcuts which X-Plane has been configured to recognize.

This works for everything except heading selector, course selector and barometer. For these, X-Plane 11 recognizes the commands in the settings menu where keyboard commands can be mapped (rotating the knob causes X-Plane to register the corresponding keyboard shortcut), but when flying, rotating the same knob does not trigger the intended changes - there is still a knob turning sound generated by X-Plane indicating the keystrokes are making it through, but the heading selector value (as an example) remains unchanged. Even more confusingly, tapping the same keyboard shortcut using the keyboard changes the heading selector. This issue does not affect all knobs either - the range knob and the comms/nav radio freq. selector knobs work perfectly. I even tried programming one of those knobs which work correctly to instead change the heading, but even that failed.

What could be going on here? I have tried multiple keyboard shortcuts including ones with just a single key, and this issue persists. Clearly X-Plane is getting the virtual keyboard command, else it wouldn't register when in the settings menu, but somehow it's losing the ability to react to that same set of virtual keystrokes when they happen while flying.

Any help/ideas would be deeply appreciated.

commented by (19.3k points)
Have you tried in multiple aircraft with the same result? Can you provide a specific example, such as what aircraft are you using, and which specific keyboard command in settings you picked?
commented by (14 points)
This happens on the G1000 in both the 172 and the Cirrus Jet. I have tried multiple keyboard command variations, including just single non-modifier keys (e.g. i and j).

Please log in or register to answer this question.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...