0 votes
asked by (12 points)

Log.txt here:

http://questions.x-plane.com/?qa=blob&qa_blobid=5805566001311626171

I am getting a message "error: linking with uncompiled/unspecialized shader" when attempting to run X Plane on Ubuntu 18.4.2. I would buy X Plane 11 but my hardware isn't supported by 11

Reading tickets on a similar subject makes me think that my Intel Ironlake GPU and its Mesa driver are the issue. I've tried Ubuntu 14 and 16 in an attempt to obtain different versions of the GPU driver, and attempted to 'upgrade to a proprietary driver' but I've not found a solution ... and it sounds like Mesa might be the only driver. glxinfo states that it supports OpenGL ES 2.0 and runs Mesa 18.2.8

Is there anything I can do to get XP10 working? Thank you.

The error message in the terminal is this:

Trying 'libdbus-1.so.3
Gnome Screensaver inhibited.
Resources/shaders/terrain_vert.glsl: 0:171(31): error: syntax error, unexpected NEW_IDENTIFIER, expecting '{'
Resources/shaders/terrain_frag.glsl: 0:171(31): error: syntax error, unexpected NEW_IDENTIFIER, expecting '{'
Resources/shaders/terrain_vert.glsl+Resources/shaders/terrain_frag.glsl: error: linking with uncompiled/unspecialized shadererror: linking with uncompiled/unspecialized shade

I will attempt to attach the log.txt.

Please log in or register to answer this question.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...