This site is being deprecated.

Please see the official X‑Plane Support page for help.

+1 vote
asked by (14 points)

not sure if this is a bug with ATC or I'm just really unlucky!

almost every time I fly from EGNM (leeds & Bradford) to EGCC (Manchester)

I fly to POL from EGNM then ATC starts redirected me to EGCC to land.

upon final approach I'm given clearance to land and then 2 or 3 seconds later ATC will tell another aircraft to take off, then redirects me to 050 @ 5000Ft and then promptly forgets about me.

am I doing something wrong or is this a bug?


I'm running X-Plane 10.42 on a Debian Linux Box via steam

32GB of Ram, Nvidia 970

1 Answer

+1 vote
answered by (19.3k points)
Unfortunately, it is most likely a problem with the default ATC and/or AI Aircraft. They are...not very bright. We are working on some bug fixes that we hope will make it much better to use, but they are not out yet. I know that is not very helpful, and this next suggestion isn't very realistic, but the only thing that you can really do at the moment to make ATC better for your flight would be to turn off or reduce the AI aircraft so they can't get in the way.
commented by (14 points)
Thank you for your honesty lol :D
I didn't know I could turn down the number of other aircraft.  This is a good solution for the time as I hate getting caught in a "gate change" for 45min also
commented by (19.3k points)
You can change the number or type of AI aircraft by going to Aircraft menu -> Aircraft & Situations screen -> Other Aircraft tab. Setting the number to 1 will remove all default aircraft and leave only yours.