0 votes
asked by (12 points)
I am recently experiencing constant stuttering using xplane 10.42. It will fly for a few seconds and then stuttering for a second or two and this will be continuous - fly and then stutter again. I have never had this problem before. I have the latest NVidia drivers for my GeForce GTX 970. I am using windows 7 with 32GB of ram and my video card is a 4gb. My frame rate is high and then it will drop drastically during the stutter and then resume high frame rates again. Does anyone know what could be causing this? I have tried loading older drivers but that has not helped either. My rendering setting is moderate so that should not be causing the issue.

Thanks for any help anyone can offer.

John

1 Answer

0 votes
answered by (19.3k points)
Hi John,

Have you noticed any pattern with the stuttering problem? Does it only happen when you're in a certain area? The type of scenery and objects in your view can have a big impact on frame rates. For example, are your FPS high when looking out over water but the stuttering starts if a city comes into view? Is it in every plane? Or does it happen when you're in straight and level flight, not touching anything?

If there are any patterns you can find, it would be helpful to know to try to reproduce or test this.
commented by (12 points)
First, thank you for taking your time to respond. I sincerely appreciate it.

It now happens with every plane I use and location/area does not make a difference. If no one else is having a problem with the latest update (10.42), I would have to assume then that it is my problem and related to video card or plugins - even though I have not added any new ones recently.

The only difference I  have achieved is restarting xplane sometimes cuts the stuttering down a fraction but it is still there.

Thanks again for your advice.
John
commented by (19.3k points)
I have't seen your log.txt file to see what type of plugins or add ons you have, but one way to troubleshoot those is "divide & conquer": remove half and see if the problem is still there. Keep taking half away until you can figure out which specific thing is the problem.
commented by (12 points)
Plugins did it! Interesting since I did not add any recently but the stuttering appears to be gone after removing quite a few plugins.   Thanks for your help.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...