This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (16 points)

I have an annoying microstutter that usually occurs every 3-15 seconds. I do not believe it is related to XP11 being in early beta as i experienced the exact same with XP10. I usually get 40-50 fps, however when the microstutter occurs the f-sim drops down to 19.90 than straight back up to its normal value. It seems to be more pronounced/consistent in heavy object areas or with more complex planes, however still can occur in a small cessna over a small town.

Having absolutely no trees or buildings reduces the effect drastically however it is still very subtly there every 20-30 seconds or so. I have talked to others that seem to have this problem with a gtx 1070 or 1080.

Note i have tried the common nvidia tweaks such as threaded optimisation off.


1 Answer

+1 vote
answered by (19.3k points)
selected by
Best answer
Since you mentioned that turning off objects seems to help a lot, it could be an issue with your CPU. The sliders on the right side of the Graphics screen are more CPU heavy. In general, graphics will be limited by either the CPU or GPU--and it sounds like your GPU is a fairly new and powerful one.
commented by (16 points)

Yes I think you are right; I also tried using another person graphics card which is the same model as mine (Which doesnt have stutters on their system) and the stutters were pretty much the same in terms of how noticeable and frequent they were. I dont seem to notice stutters like what I observe in X-plane on any other game, which seems a bit odd but I dont know too much about it.

Do you know of anything that I could do to further find the specific cause?

commented by (16 points)
It's been months since you started this thread. Did you figure out how to correct the stuttering?

commented by (16 points)
Hi there.

I didn't find any specific fix. However I have noticed it less and less as XP11 has gone through the early updates. I still have the stutter a little, but it does seem much more smooth than what I remembered.

Sorry I can't give you any possible solutions if you are experiencing the same. Make sure (if you haven't done so already) that you do the tweaks in nvidia control panel (like threaded optimisation -> off, power management mode -> prefer max performance, etc) as they seemed to help a bit.

commented by (16 points)
Thank you for replying. I called the GPU mfr and they suggested the exact same settings. I can't tell that it helped much. Guess, I'll have to live with the stuttering (unless I can figure out exactly how to solve it) because there is NO WAY I can go back to using MS Flgt Sim.


This site is no longer being actively maintained.

Please see the official X‑Plane Support page for help.