0 votes
asked by (12 points)
I hope this isn't a completely unreasonable question or a waste of anyone's time.I have an early 2008 Mac Pro with dual, quad-core Xeon processors running at 2.8 GHz. So far, I've been able to upgrade it to keep up with X-Plane's requirements including a solid state drive, 16 GB RAM and the Nvidia GTX 906 with 4 GB VRAM. It runs XP 10.5 acceptably (frame rate 25 - usable though not ideal), but the 11.02 demo frame rate is only 9 to 14. I realize this machine could charitably be described as a dinosaur, and that I will have to replace it sooner rather than later. However, based on the minimum and recommended system requirements, it seemed reasonable to hope that XP 11 would not perform that much worse than version 10.5.

Different combinations of graphics rendering options in XP 11 result in only small changes in frame rate. The X-Plane.org forums suggest that this may be due to Threaded Optimization being on in the video card. Windows users can easily turn this off with the Nvidia control panel, which apparently does not exist in Mac OS X (10.11.6.)

If anyone knows how change Threaded Optimization on a Mac (perhaps using Terminal commands or scripts?), I'd appreciate your help. Alternatively, might there be a way to tweak XP 11 to eliminate the conflict with the video card? I'd greatly appreciate any help I can get, even if the verdict is that there is no way to fix this problem.  Thank you very much.

1 Answer

0 votes
answered by (3.5k points)
Hi,

I couldn't find how to disable threaded optimisation on Mac OS, but i was thinking you could try to lower the resolution to Full HD (1980 X 1024) or similar to respect your screen radio, still in full screen.
Of course, disable shadows and Vsync and make sure your demo is up to date (if applicable).

What frame rate do you get with these settings?

regards,
Guillaume
commented by (3.5k points)
Can you include your x-plane 11/log.txt?
commented by (3.5k points)
Finally found something :

Maybe command lines would help you disable threaded optimisation. This will probably answer your question :

http://www.x-plane.com/kb/using-command-line-options/

According to Laminar Research, this article also mostly applies to X-plane 11.
commented by (12 points)

Bonjour Guillaume,

Thank you for replying. As soon as I get a chance, I'll check the resolution and try Full HD if applicable. The demo time limit makes experimenting with settings a bit difficult, since I often have to restart the program. I'm sure Vsync and shadows were disabled.

Here is my log file. Sorry, If I'd been thinking, I would have attached it to my question.

Thanks for the link to command line options. There is one intriguing option:

      --no_threaded_ogl
      Disable the use of OpenGL via multiple threads.

I don't know if that really means disabling Threaded Optimization, but it's worth trying. I'll let you know what happens.

I really appreciate your help.

Don

 

commented by (3.5k points)
"There is one intriguing option:

      --no_threaded_ogl
      Disable the use of OpenGL via multiple threads.

I don't know if that really means disabling Threaded Optimization, but it's worth trying."

I thought exactly the same thing as you :)
commented by (12 points)
Guillaume,

I didn't have an option to set the resolution at exactly 1980 x 1024, but using two similar resolutions (1920 x 1200  and 1920 x 1080) made no difference. Loading X-Plane with the command line option --no_threaded_ogl unfortunately also had no effect. I did see a difference in frame rate between very low and very high rendering settings, though. With most of the sliders set high, frame rate varied from 8 to 10. With low settings it was usually 15 to 16, although occasionally it stabilized as high as 19 to 20. The whole thing is a mystery. I still suspect that the video card is using Threaded Optimization, which apparently can't be changed on the Mac. It's clearly an  XP 11 problem. As I mentioned, frame rates in 10.5 are 25 with the default rendering settings. If I decrease the texture quality, number of objects and antialiasing a bit, frame rate increases to 29 to 30 with video quality that is still sufficient for my purposes. Maybe I'll submit a bug report and see what happens.

I have screen captures of some of the above examples that I'd be happy to upload if you want to see them.  won't take up more space on the server if its not necessary.

Thank you again for your help - Merci. (I'm straining the capacity of what little French I still remember from two years of high school French - 1962-3).

Don.
commented by (3.5k points)
Haha, thank you Don for your nice comments :)
I'm sorry i couldn't help you more though.

Adding more reference to this topic will always be useful when someone from Laminar Research reads this topic, so I can only encourage you to do so.

Filing a bug report might be redundant, but it can't be harmful.

All the best with this!
commented by (12 points)
Guillaume,

To their credit, Laminar responded quickly to my "bug" report. They believe the problem is that my CPU can't handle the built-in, increased graphics "bells and whistles" that are an integral part of version 11. After some more experimentation, I think they are correct. I knew this day would come eventually, but I was hoping that having dual 4-core processors might make up for the old CPU version and slow clock speed. Guess I'll have to choose between staying with version 10 or getting a new, much faster computer. The latter is tempting and kind of exciting, but I'd really rather not spend the money right now when my old Mac still does everything else just fine.

Thanks again for your help.

Don

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...