This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (12 points)
Whenever I adjust the pitch, I end up zooming in or out and basically it makes the program unusable. For example, I pitch nose down and end up zooming into the controls. I pitch nose up and end up zooming back behind the seat. I am using a 3d connexion 3d mouse.

The plane still does pitch while doing this, but zooms simultaneously.

It is calibrated and works well aside from the zooming issue. Is there a way to lock a view in place, or turn of the ability to zoom and alter the view?


commented by (10 points)
This is exactly the problem I have. I'm a new XP11 user with a 3dconnexion SpaceMouse that works fine in other programs. It is a 6-dof (3-rot, 3-tran) force sensitive control; In my setup I have only selected the 3 rotations for yaw, roll & pitch. No external devices are setup to control zoom, yet use of the pitch axis drives the zoom (along with valid pitch actuation) to the point that flight is impossible. I have created new Preferences folders a number of times with no improvement in performance. Since nothing in my setup uses the zoom feature I can only imagine that it is some form of program bug, but I may be just a puzzled newcomer.
commented by (12 points)
I haven't played in forever, but I remember fixing it was simple. I went to the 3d mouse settings and simply turned off zoom. It worked fine after that.

Then after about 30 hours I had my fill of the game and went back to chasing tail.

1 Answer

0 votes
answered by (3.5k points)
Hi, you should delete (or move for backup) the entire ...\X-plane 11\Output\Preferences folder. You will lose all your settings but this is likely to solve this kind of problem (most likely a conflict between assigned functions).
commented by (12 points)
Haven't played in a while, lol. It still zooms after deleting folder and settings. I know this must have happened to someone else. Lot of people have 3d space mouses. I will keep playing around with it.