This site is being deprecated.

Please see the official X‑Plane Support page for help.

+6 votes
asked by (18 points)

I have setup eGPU with EXP GDC Beast v. 8.4 dock and Asus GTX 550 Ti GPU via Expresscard. My laptop is HP Elitebook 8570w, with i7-3740QM prosessor and 16 GB of DDR. OS Win10 Pro. Onboard GPU (Nvidia Quadro K1000M have been disable) Hardware setup is working correctly. nVidia driver version is GeForce 385.12 WHQL

I have made wide variety of benchmarks with my setup using Unigine Heaven and Valley benchmarks and FurMark benchmark. All bencmarks have been made with OpenGL API. All benchmarks gives me satisfactory results with normal quality and anti-aliasing settings. Rendering with these benchmark softwares executes smoothly without twitching between 17-40 FPS.

The problem is this: When I start X-Plane11 with default rendering settings FPS count is 1-2 FPS, and altering rendering setting from X-Plane, NVidia drivers etc does not make any difference. Somehow it feels like there is foot on the brake pedal in X-Plane code. How it is possible, that other softwares like benchmark softwares that utilzes OpenGL API works ok, but X-Plane works not.

I have investigated practically all available solutions to overcome this problem without any luck. All symptoms points now on X-plane, and how it utilized OpenGL API. In my view this is a bug, and I'm quite certain that it can be fixed. I strongly hope so, because the sim is fabulous after all!
commented by (27 points)
I have a similar problem in MacOS with an eGPU. The performance with te onboard cards is ok at 20_fps. With a 8GB card in the eGPU I get <10fps !
commented by (12 points)
I have the same issue on my 2017 MacBook Pro (onboard Radeon Pro 560 4GB) with eGPU Radeon RX 580 8GB. When Running XP11 I get 20+ fps with the onboard Radeon Pro 560 4GB but only 10 +/- with eGPU Radeon RX 580 8GB. I did run the Unigine Heaven Benchmark on both the onboard and eGPU and the eGPU card produced +25 fps compared  to the onboard.
commented by (25 points)

I also want to add myself as a +1 of another user of this same issue, with the same configuration:

I have the same issue on my 2017 MacBook Pro (onboard Radeon Pro 560 4GB) with eGPU Radeon RX 580 8GB. When Running XP11 I get 20+ fps with the onboard Radeon Pro 560 4GB but only 10 +/- with eGPU Radeon RX 580 8GB

1 Answer

+2 votes
answered by (27 points)
I have reported it to Laminar, who I'm happy to say responded very promptly to say it is already noted as an issue/bug. It is not currently supported in MacOS version. But they know about the issue and so hopefully at some point things will improve.

However, I have had success using the set-up in Bootcamp (windows) on the MacBook. Your license will work for the windows version too.The eGPU outperforms the onboard here. I was put off trying bootcamp due to all the complicated instructions on, but it seems that on this MacBook (purchased January 18) everything was simply plug and play - no fiddling! But be warned - others with different set-ups don't have such an easy time (

For me:

On High Sierra 10.13.3 (no betas).

A fresh bootcamp install, fully updated.

Boot into windows and plugin in the eGPU

Let windows install drivers. Reboot etc as prompted.

I then used device manager to update drivers, just to make sure have latest

Now in X-plane, I can have HDR enabled, and can even run with max objects, though one notch down gets me ~30 fps reliably. In some places on the map it pushes 40fps. I'm even tempted to try and get a Vega 56/64 to see how much more I can get out of it. Though it is clear that the cpu is also a limit at various points. Not tried nvidia as I have stuck with Radeon for now since Apple tends to be supporting natively.

But honestly, it works in Windows Bootcamp. Try it!

I will just have to be patient for it to be better in MacOS too and for now have to put up with rebooting into windows.
commented by (25 points)
@thyde Thank you for reporting. How did you go about doing this? And any ETA? Or a chance you can paste back what they wrote, please? It’s started to affect quite as few of us now...
commented by (27 points)
Sure, all they said was...

This is a known bug at this time, filed as XPD-8996. X-Plane has not been tested with or optimized for external GPUs.