This site is being deprecated.

Please see the official X‑Plane Support page for help.

+1 vote
asked by (17 points)
I'm sure the game has auto-rudder. I have a saitek rudder paddle configured and calibrated however the game is with the auto-rudder function. How do I disable it? This is killing my immersion. I searched a lot and still did not see any developers pronouncing about it.

Can anyone help me?
commented by (18 points)
For those of you who observed like me autocoordination during turns even with a yaw axis assigned to a rudder or a joystick that is supposed to deactivate the autocoordination feature according LR:  the bug is coming from the stability augmentation that is currently working the other way around.  It has to be set at 100% which is giving no aids (this is why it is a big because no aid corresponds to 0%)

3 Answers

+1 vote
answered by (16 points)
I have done hours of looking up on how to do this with no avail. Realllllly wish laminar would give us some info but there is just silence on this issue.
commented by (17 points)

Yeah, me too, hours and hours of research.

And basically always Laminar answer "If the rudder pedals are set up correctly, they should replace auto rudder". (I don't know if jroberts is a staff, just saying that I saw this answer several times on other places)

commented by (16 points)
Well if he is staff he needs to know this is a bug by now and it needs to be fixed because it was not fixed in 11.10 beta yet
commented by (17 points)
I just can't imagine why a simulator so good is lacking such a basic function, and anyon is carrying about. =/
0 votes
answered by (19.3k points)
If the rudder pedals are set up correctly, they should replace auto rudder (intended mostly to work with people flying with a mouse only). Please try recalibrating the pedals.
commented by (17 points) 1 flag
My saitek rudder peddals has all the drivers, is well calibrated but the turns are always coordinated, even turns like 60ยบ.

I'm almost stopping to play X Plane, this is pretty bad.
commented by (20 points)

I agree this is a showstopper.

I just purchased new rudder pedals (Saitek) but the turns are always coordinated.

I have recalibrated several times but nothing helps (running on a Mac)

It seems that the auto yaw is always activated. 

Right now I have a set of pedals I cannot use. I hope Laminar Research can fix this asap since it is a big problem.

commented by (19.3k points)

If you believe you have found a bug, file a bug report here

You'll need to be as methodical and detailed about your investigation of the bug as possible. Here are instructions on how to see joystick input on screen to see if there is an issue with the device to rule that out first. Make sure to include what you've tried in the bug report and be as specific as possible in the Steps field.

It will also be helpful to try the 11.10 beta if you are not using it to see if has already been fixed there.

commented by (17 points)
I already did this several times. :)

I'm beginning to believe that Laminar Research doesn't care about this. I read in a lot of places, people talking about this problem, and nothing happens
commented by (19.3k points)

I've seen a lot of complaining here about this possibly being an issue, but no bug reports with actual information about any troubleshooting or actual step by step instructions to prove this issue. We look at every bug report. We are a small team with limited time and resources to investigate everything. Help us help you by doing a little legwork on your own, then submitting a bug report we can actually use.

commented by (20 points)
I think I might have been mistaken.

It might be that I was misinterpreting how much rudder is needed to get the turn coordinated (not very much). OR the rudder might have been faulty requiring multiple recalibration tries.

Treat my comment as "solved". I will report a bug in case the problem returns.


Best regards,

commented by (17 points)
Ok no problem, I will make anothere bug report

Just searching on google you se A LOT of the same complaining.


When you plug your rudder paddles your X Plane Auto Rudder becames disabled?
Because for me seems like you guys never even tried this
0 votes
answered by (18 points)
Any news regarding the auto rudder disabling option? We have a wonderful sim with awesome flight dynamics but with autorudder...kinda of weird.
I have the RD1 rudder from Redbird and correctly calibrated.  But all the turns even high bank remain coordinated without the need of rudder inputs.
A file to tweak or something would be already nice.

commented by (17 points)

I opened a bug report and here is the answer I received:

"We are investigating this further. One of the pilots on the team will be using a real aircraft for investigation, so the fix will most likely be in a later update (not 11.10)."


Please, do the same and open one too here