This site is being deprecated.

Please see the official X‑Plane Support page for help.

+1 vote
asked by (13 points)
edited by
I normally fly X-Plane 11 with my CH Products Flight SIM Yoke and Pro [Rudder] Pedals, however, whether they are connected or not, the inside cockpit view (upon booting) immediately drifts to the ceiling. Is there a setting I'm missing to correct this? I can use the hat switch on the right top of the yoke to bring the view to look out of the cockpit (front) view normally, but when released, the view immediately drifts right back up, looking straight up at the ceiling.

My PC is a ROG (Republic of Gamer) tower, more specifically:

ASUS Desktop PC G20CB Series, Intel Core i7-6700 CPU @3.40Ghz x2 (dual core) 64-bit OS.

Thanks in advance for any help! I've been through all the settings and can't seem to find anything to fix this. It was working normally up until today.


UPDATE: I have managed to get the forward facing view from the cockpit in settings by clicking on View>Change(Internal)>Forward with 2-D panel (or ALT + w). However, once I move my view within the cockpit and attempt to again have a forward facing view, the view drifts back up to the ceiling. I have to repeat the steps above to regain a forward facing view from the cockpit, and I'm still baffled as to why and more importantly how to fix this.

Thanks again for any help!

1 Answer

0 votes
answered by (19.3k points)
Try removing all plugins to see if they are adjusting the camera. Move the preferences folder (found in the Output folder) to the desktop, then restart X‑Plane and default preferences will be restored. If the default preferences do not fix your problem, you can simply replace them with the folder you moved to the desktop and restore your personalized settings.