0 votes
asked by (14 points)
When I first loaded x-plane 11, it ran fine in my main monitor.  When experimenting with the settings, I changed to "Monitor 1" (the 2d monitor) and Full screen, x-plane stopped recognizing my Main Monitor and will ONLY run on my 2d monitor.  How do I get x-plane to return to my Main Monitor?

2 Answers

+1 vote
answered by (19.3k points)
You will need to reset the monitor configuration in settings. As a last ditch option, if you don't remember how it was configured before, you can completely reset your preferences to get the same settings as when you first launched X-Plane.

Move the preferences folder (found in the Output folder) to the desktop, then restart X‑Plane and default preferences will be restored. If the default preferences do not fix your problem, you can simply replace them with the folder you moved to the desktop and restore your personalized settings.
+1 vote
answered by (47 points)
I second what jroberts said, OR, you can keep most preferences and only delete or rename just the two video related preference files: "X-Plane Screen Res.prf" & "X-Plane Window Positions.prf".
commented by (14 points)
Thank you - between your identification of the files and jroberts' pointing out the correct folder, I was able to modify (a copy of) the .prf file and all is working again!

Is X-plane's counter zero-based?  It states "number of monitors: 1", yet the main monitor is "0".
commented by (47 points)
Correct, first monitor is index zero.  In a four monitor system they'd be zero to three.  And, just to keep things interesting, I believe the primary monitor (the one with XPlane menus) is always monitor zero.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...