This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (15 points)
I've succeeded in getting the weather settings changed to temps in celcius and QNH in hectopascals but the ATC only announces QNH as inHg.

Is there a way to change it or is this not possible?

2 Answers

+1 vote
answered by (45 points)
Well go into flight configuration and go into weather. Now next to the pressure slide there should be a button you can click to get how. Hope this helps.
commented by (15 points)
Thanks, this works.

Btw, when displaying the raw data at the top of the screen, that doesn't change from inHg.


0 votes
answered by (26 points)
This usually set by an option in each aircraft, so using planemaker might be a start.  But, generally, if not addressed by the acf file for an aircraft, there is a setting in your preference file that can address all barometric and temps that are not set up for each aircraft.  Make sure XPLANE or PLANEMAKER is not running.

In your XPLANE/OUTPUT directory there is a PREFERENCES directory that has all of the settings you have set while using the simulator, whether it be for user profile, joystick and keyboard settings, etc.  CAUTION, make a copy of these files BEFORE you even open them because even the smallest of changes can effect performance.  These are ascii text files, only edit with a text editor that does not save in rich text.

In the xplane.prf file find the two lines:

_metric_temp 0
_metric_press 0

0 = off 1 = on

Change the 0 to a 1 and save the file do not change the file type or name.

This will change all temps and bars to metric, if not addressed by a specific piece of equipment, i.e., the G1000 has a setting for the barometric units for either in or hpa.   Other aircraft may have similar settings so if you want to change them, try looking in to the plug-in options or again planemaker.  Payware aircraft and plugins may completely override or ignore these preferences.  

Hope that helps.  ;)
commented by (15 points)
Hi DR1X,

Thanks for your reply.

The X-Plane.prf is set correctly (thanks for telling me about the file) for metric temps and pressures.  I'd changed the settings in custom weather and then swapping back to real weather.

The problem is that ATC still announces (audio and text) pressure as inHg (and data display also shows inHg but temps in celsius).

I had switched all my planes to use metric pressure, but then ATC wasn't co-operating so no go there.

Any chance this is a bug in 11.3r1 ??

I'm only trying to do this because that's what I expect to hear from ATC when I fly real planes in Oz.