0 votes
asked by (605 points)

I was running X-Plane 11 on monitor 1 only, achieving 30 FPS under the following display config:

  Monitor 1: 1440p, display port, driven from RTX 2070 card

  Monitor 2: 1080p, HDMI port, driven from RTX 2070 card above

  Monitor 3: 1080p, HDMI port, driven from motherboard Intel video out.

Then I attempted to divert monitor 2 to be driven by the motherboard's display card as well, i.e.:

  Monitor 1: 1440p, display port, driven from RTX 2070 card

  Monitor 2: 1080p, DVI port, driven from motherboard Intel video out

  Monitor 3: 1080p, HDMI port, driven from motherboard Intel video out.

Windows 10 runs fine with the new config.  But X-Plane is getting 1 FPS!

The single display that runs X-Plane is still with the RTX card, however, it looks like as if it was running without any benefit from the RTX hardware.  My intention was to dedicate the RTX card solely to drive a single monitor, maximizing it for X-Plane’s use.

Any idea what’s going on?  How to fix it?

Thanks.

commented by (605 points)

More observations:

I believe the reason is when X-Plane launches, it somehow has determined and latched onto using the motherboard integrated video to render.  Even if I manually switch X-Plane to the monitor attached to the RTX card, the output does move to the desired monitor, but X-Plane continues to employ the inadequate integrated video for rendering.  The RTX engine sits idle while X-Plane runs.

I wish there is a way to configure X-Plane to utilize and to default to a selected video GPU.

1 Answer

0 votes
answered by (5k points)
selected by
 
Best answer

Hi disc,

I am not with Laminar Research; just a flight simmer.

You have created your own problem by connecting your screen(s) to the motherboard.  It just won't work.  There is insufficient "grunt" to be able to do what you want.

The CPU needs as much grunt on its own without any extras.  You need a dedicated graphics card to successfully run X-Plane.  X-Plane is resource hungry in both CPU and GPU. 

Trawl back through this forum for a comment by jroberts (Laminar) making the same comment about not connecting to the motherboard.

If you also trawl through the videos in recent times at the following link  https://www.youtube.com/user/col2mab/videos   from Michael Brown you will find the same comment.  Michael build PCs predominantly for X-Plane.  You will also find some additional useful information on how to PROPERLY configure your monitors.  Also read the manual on configuring and using multiple monitors.

Connect your screens to the graphics card only with the 1440 unit as your middle screen and you should get better than 30 fps

Glenn

commented by (605 points)

Thanks very much for the answer.

Yes, I have also discovered empirically that the best framerate can be had by connecting all monitors to the video card (with integrated video disabled).  X-Plane gains a few FPS by doing so.  It is still interesting how X-Plane could find itself not utilizing the RTX graphic engine at all, while the card is actively driving a monitor (in the above configuration)?  But anyway, that’s irrelevant since it is optimal to have all monitors be driven by the video card.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...