This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (66 points)
I was up at 35000 ft (that might not be the correct altitude of a 737 but I did not have all the experience of a pilot yet).  The cockpit started to turn dark it was almost pitch black.  I went to the shift 4 view and the light was just normal again.  (It was around 10:30 Am).  Is this a bug or an actual thing?  And how do I prevent it from happening again?
commented by (10 points)
Agreed: Mine has done the same thing.  

This happened while while flying a recently updated A/C from V-10 (a 337 not a 737). I was in manual cruise and everything was hunky dory, then slowly the lights went out in the middle of the day, until it was black. Cursor was OK, as were the top menu items and I was able to get a chase visual OK, plus the Map worked fine. Had to shut down to regain control.

My Video card is a high end PC card and I have plenty of RAM on a Quad core. + the Most recent update on X-Plane 11

Any ideas out there.
commented by (66 points)
edited by
Further information on this problem...If I use the mini map altitude slider to go to 35000 ft, then the cockpit does not turn dark (the problem doesn't happen).  The problem only happens when I take off normally and happens with each flight.  When this does happen, everything outside the aircraft looks normal.  The controls still work.  But a view of the cabin is also completely dark.

Are any other x-plane pilots experiencing this besides Captron?  It is very frustrating!!  If someone has already submitted a bug report, please let us know.  If not, I will try to put one together...Captron, please let me if you have anything to add to your description of the problem.


1 Answer

0 votes
answered by (685 points)

Well, you’ve probably forgot to pay your electric bill…   Just kidding!

It sounds like you’ve experienced hypoxia and blackout.  See if you have the “Simulate blackout…” option checked in X-Plane General Settings.

In the Laminar default B738, the cabin pressurization is only partially implemented.  Thus, if you have just left things alone from a “Start with engines running” launch, the cabin would have remained pressurized.  But verify the two switches located at the bottom of the L Pack and R Pack in the overhead Bleed Air controls section—they all should be ON.

commented by (66 points)
Thanks a lot for your help, I will try it.  I like your electric bill joke.  Thanks!
commented by (10 points)
Hi Disc, Hmm doesn't help though with the same issue at 1,000AGL  2500ASL
commented by (685 points)

At 2,500MSL, the “blackout” could not be from lack of pressurization.  You can uncheck the “Simulate blackout…” option in General Settings to confirm whether this occurrence is indeed hypoxia/blackout.