0 votes
asked by (16 points)
Hi,

Just installed my new GTX 1080 and there is no visible FPS difference in X-Plane comparing with my previous GTX 980.

In other applications or games, there is huge difference.

Any idea why is that?

Thanks

Uru

1 Answer

0 votes
answered by (18 points)

Hi Uru,

Good question!

In general, a given rendering setting in X-Plane will impact *either* the CPU or the GPU (i.e., the graphics card). Your overall framerate will be limited by whichever of those two is most heavily loaded.

In the ideal case, your rendering settings would be perfectly tuned to keep both your CPU and GPU fully loaded at whatever frame rate target you're trying to hit (often 30 frames per second).

But, if one component is overloaded---for instance, if the CPU-affecting settings are turned up much higher than the GPU-affecting settings---that component will become the limiting factor; it will "bottleneck" the rest of the system. In this case---with the CPU bottlenecking the framerate---you could swap in a hypothetical infinitely powerful graphics card and see little to no performance improvement... because it wasn't the GPU that was limiting your framerate in the first place.

So, my recommendation would be: check and make sure you're not bottlenecked on your CPU. The rendering options portions of the manual should give you an indication of which settings affect the CPU versus GPU. Likewise, the section on tuning the rendering options for best performance may be of use---it will walk through turning down all the rendering options to start with, then slowly turning things up until you find the best setting for your machine.

Do let me know if that isn't clear! :)

commented by (12 points)
Hi Tyler,

in my case X-Plane 10.45 worked very well on my brandnew pc in the beginning with a file-size of 320 GBs with heaps of plugins, z-sceneries, airports, tons of aircraft....etc. - Then all the sudden I got a frame-rate of 6-12 fps so X-Plane can't be used as a simulator any more.

We did benchmark-tests on the CPU, GPU, Motherboard, SSD-drive.....the result is that I got a working i7 4 GHZ processor, a very fast graphic-card, 32 GBs of RAM with a 8 GB VRAM......but I still can't getter a higher framerate, even with no plugins, sceneries, libraries or additional aircraft installed...just "naked" X-Plane 10.45 with a Cessna 172 and all rendering options turned down don't help the problem with an extremly slow frame-rate!

Reinstalling the operating-system (Windows 10 pro) and reinstalling X-Plane through the 8 DVDs and through download didn't solve the problem either. - Could it be that there is a bug in X-Plane??
commented by (449 points)

Hi Frank,

It might be worth posting a new question for this, but my first troubleshooting step would be to ensure other applications run as well as expected. For instance, you mentioned benchmarks---does Furmark (an OpenGL graphics benchmark) run as well on your machine as on other machines with the same graphics card? (Furmark is of particular interest, because it's the only benchmark I know of that uses OpenGL, the graphics library used by X-Plane, rather than DirectX.)

commented by (866 points)
Frank,

It sounds like either a strange issue with X-Plane or more likely a problem regarding Windows 10 (other problems, this September 2016 after your comment, have been reported with the seemingly apparent culprit of the Windows 10 OS opposed to X-Plane 10 alone).

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...