This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (12 points)
Bought the sim yesterday and loving it. Linux 64 bit. I hit enter to bring up the ATC window I then setup my flight plan - EGPF to EGPH (Glasgow to Edinburgh). I file the flight plan then hit enter again only to see the same dialogue asking me to file a flight plan, this just repeats. I then created a couple of flight plans using xFlightPlanner, setup a button on my joystick to load the FMS, I still can't load a flight plan but get the same repeating dialogue.

Doesn't matter which plane I'm flying or airports, routes or direct.

1 Answer

0 votes
answered by (19.3k points)
Hi TonyM,

Double check that your com 1 radio is tuned to the correct frequency. It sounds like your flight plan is being filed, but that you don't see any new options when you bring up the ATC box after that. That is because the frequency is not set to continue to the next step (Request clearance).

You might find it easier to use the Nearby ATC box which is found under the special menu. You can check the box to auto-tune frequencies and the next option should always be available.
commented by (12 points)
I had thought that might be the issue when I first encountered it but I still get the same behaviour with com1 tuned to the correct frequency for Glasgow either by hand or using the Nearby ATC box. After I posted this question I tried several different scenarios but no joy it constantly asks me to file a flight plan when I open the ATC dialogue.
commented by (19.3k points)
Do you have custom scenery? I have the option to request clearance as well as file flight plan when the EGPF Ground Control 121.70 line is highlighted in the Nearby ATC box.
commented by (12 points)
Ah, I think you've got it, I was tuning to the tower on 118.8. I'll check this out later when I get home.

commented by (12 points)
I was using the wrong frequency, all working as it should,

Thanks again!