0 votes
asked by (16 points)
Hello there,

For some reason, XPLANE new update has got the simulator to get 7 fps

The dropped happens not inmediatly after the program loads but just seconds, or minutes after the aircraft is loaded, it happens randomly. I never had this problem before and I was getting quite a good fps.

I have tried changing settings, rendering, resolution, everything. I still get the problem and it is annoying as I cannot use the sim anymore.Even I deactivated third party addons just in case...

My computer specs below>

WINDOWS 10 64 bit

Intel I7-3770 at 3.40

16GB RAM

NVIDIA GEFORCE GTX 770

Any help will be very much appreciated...

2 Answers

0 votes
answered by (19.3k points)
You can try renaming your preferences folder (found in X-Plane's Output folder) to restore defaults. You can restore it if that doesn't help.

If you have the Windows 10 anniversary update installed, we have heard reports that using alt + tab can cause loss of fps as well, so try to avoid using that feature.
commented by (16 points)
Hello there,

I have tried option 1, not working.

Option 2... Randomly, again, the FPS gone down. I tried to go back to the previous version and in fact, I was running it okay until now.

Out of the blue FPS down to 7....

I am upset as I cannot use the sim anymore that I am forced to use alternatives.

I would like to know whether this is a known problem and, if this is the case, why was not happening before, any ideas?

Thanks for your help

Israel
commented by (19.3k points)

There are known issues with the Windows 10 anniversary update. 

If you have the Windows 10 anniversary update and are experiencing FPS problems:

  1. Open Xbox app
  2. Sign in with your Microsoft account
  3. Click on the settings "gear" icon at the bottom of the left-hand sidebar.
  4. Click the Game DVR tab.
  5. Toggle "Take screenshots using Game DVR" to off.

Please see this knowledge base article for more information.

0 votes
answered by (32 points)
Hi Sir,

I had a strikingly similiar problem after updating to 10.50. I also have a GTX 770 (Asus), Windows 10 64-bit (with the latest updates). My frame rates would "very randomly" drop to 19.90 (and always that). I have a i7-4790 processor which appears to only run at 25-30% capacity with x-plane. I kept minimizing my settings, and able to get it to work better with medium settings, but it would then still drop again to that 19.90. Very frustrating ! I was able to run x-xplane on high with no problems before the 10.50 update.

Anyhow, I deleted all plug-ins and reinstalled x-xplane and was testing it without plugins. I ran Techpower GPU-Z against it, and it appears that the culprit is it is running out of VRAM.

It is a great card, but it appears that the 2gb VRAM is just too low given all of the world view updated changes, etc. in the new version. I was thinking about updating to a  gtx 1060 card. I know, I know, but what are you going to do ? I planned on posting a question about this myself as a sanity check in the forum, and see what card is good I can get away with for the least cost. I only use my GPU for x-plane, and i like the 770, but my problem is the vram not being enough. It is a good card, but 3.5 years old, so time for a regretted update I guess.

Also, I have not used alt + tab in ms windows 10, or anything as mentioned in other answers that I think would be causing this.

Thanks.
commented by (19.3k points)

You might also try the fix for Windows 10 fps issues, just to rule out it affecting your fps:

  1. Open Xbox app
  2. Sign in with your Microsoft account
  3. Click on the settings "gear" icon at the bottom of the left-hand sidebar.
  4. Click the Game DVR tab.
  5. Toggle "Take screenshots using Game DVR" to off.

Please see this knowledge base article for more information.

commented by (32 points)
So are you guy's planning a patch for this ? I have never used the xbox app, so I don't see the coorelation.
commented by (19.3k points)
No, there is no way to patch this in X-Plane as it is a problem with the Windows operating system.

Those are the easier steps to fix the issue. The KB article also outlines more advanced steps that involve registry editing if you'd prefer to take that route (at your own risk!).
commented by (32 points)
So are you guy's working with Microsoft then to rectify? I'm not sure what you expect a user to do?
commented by (32 points)
Nope! Same issue! No worries though, it doesn't appear to be a major issue affecting a large majority of your users. I rest assured with the assumption that it's Microsofts fault. Thanks again!

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...