This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (13 points)
edited by
The Saitek Pedals don't show up in joystick panel under preferences (in the dropdown where available hardware is listed). The yoke does show and calibrates.

The same pedals work fine on Win 10 installation. 
Did anyone else run into that? Is there a workaround or is this a bug that needs filing?

1 Answer

0 votes
answered by (19.3k points)

If you have more than one piece of equipment plugged in, you will need to switch between them in the "Device" drop down. It's located in the top left corner of the image in joystick settings screen. (Additional joystick troubleshooting here.)

commented by (13 points)
... the pedals don't show up in the dropdown on Linux, on Window install they do. I'll clarify this in the Q.