0 votes
asked by (16 points)
The keyboard commands work fine, but after several switching between Safari and X plane, x plane stops taking all keyboard commands and simply "beeps" when pressing any key on the keyboard.  The controllers (joy stick, throttle, etc) still works, however.

1 Answer

0 votes
answered by (1.8k points)
If the computer beeps while you are typing, Toggle keys and/or Sticky keys are active. The Toggle Keys can emit a beep when the Lock keys are pressed. The Sticky Keys function can emit a beep when the Ctrl, Alt, Shift, and Lock keys are pressed. Use the following steps to disable Toggle Keys:
1. Click Start, and type Ease into the Start Search field.
2. Select Ease of access from the Programs list.
3. Scroll down the page and select Make the keyboard easier to use.
4. If selected, remove the selection from Turn on Sticky Keys.
5. Click Set up Sticky keys.
6. Remove the selection from Turn on Sticky Keys when SHIFT is pressed five times.
7. Click Save.
8. Remove the selection from Turn on Toggle Keys.
9. If selected, remove the selection from Turn on Toggle Keys by holding down the NUM LOCK key for 5 seconds.
10. Click Save.
commented by (16 points)
Wow. Thanks!  However I think your describing how to fix a PC. I have a Mac. Do the same steps apply with some "Mac" adjustments?
commented by (570 points)
Did you clicked on the xplane window? This happens to me too after switching to desktop, keyboard gets read by xivap instead by the SIM itself. It's a guess though.
commented by (1.8k points)
Sorry, this tip is for PC. I don't have a Mac, but as far as I know you can run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions and Test for problem in Safe Mode.
commented by (16 points)
Actually, the PC answer did help, when I translated it to Mac-talk.  I was able to find the "sticky keys" button and turned it off.  NOW I haven't had any issues, soooo...if you have a Mac, you need to find the sticky keys and turn if off (un-click it). It's located under "System preferences; Accessibility.  Just un-check sticky-keys.  

 

SO..thank you for your help!

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...