0 votes
asked by (22 points)

The computer has two graphics cards: a high-end and a low-end.  It also has multiple monitors, most connected to the high-end card, some to the low-end.  It runs Windows-10.

When starting XP-11, it seems that sometimes it uses only the low-end card and this happens when Windows has its main display set to a monitor on the low-end card.  If I switch the Windows main display to a monitor connected to the high-end card and restart XP-11, then it will use the high-end card.

I want to tell XP-11 to always use only the high-end card.  Can I do that, and if so how?

commented by (22 points)
So, the aeroclub's Open Day is now past, and was a huge success.  The simulator was fully booked.  That effort is why it took some time for me to report back here.

We got a good result in the way described below.  This may be well-known to many, sorry if I repeat something everyone knows.

(1) the computer has a single CPU with multiple cores and runs Windows 10

(2) there are two GPUs, an NVIDIA GeForce GTX1080 and a 1020.

(3) the framerate increased dramatically when more than one copy of XP11 was installed because then Windows assigned different CPU cores to each.

We now have 24fps on each of six screens, running three instances of XP11, one master and two slaves.

We have not tested sharing the data files (textures, scenery, plugins…) between the instances: each instance has everything in its own folder, which is a huge amount of duplication.  But it works.

1 Answer

0 votes
answered by (3.5k points)
Have you tried assigne X-plane to the High end GPU from the GPU settings themselves? Do not ask me the exact steps as I will not be able to describe them precisely, but this is just an idea.

This might help though :
https://www.google.fr/amp/www.pcadvisor.co.uk/how-to/pc-components/how-set-default-graphics-card-3612668/%3Famp
commented by (22 points)
Touch screens don't work.  Period.

One needs real buttons.

I'll measure the CPU/GPU but not right now.
commented by (22 points)

So… to get to the GPU usage, I needed to upgrade W10 (again; it's just as bad as with macOS or Ubuntu; one spends one's life updating).  But:

number of XP-11CPUfpsGPU1080GPU1050
silent24%-0%0%
157%25%0%
287%4045%33%
3100%3064%21%

Somehow I forgot to note the fps when a single XP11 runs.

The anomaly is that the second GPU seems to work less with 3XP11s running than with 2. But it may simply be that I did not wait long enough for the figures to stabilise.

The numbers did not depend on whether I was standing still on the runway or doing aerobatics.  It seems the second GPU does not do much, the first one works, but the CPU is used flat out!

commented by (10 points)
Ok, thanks.

Look a lot like mine, but i have fiddled a little with nvidia settings, and have got some good figures now, seem to run better with lower CPU utilization, it dropped around 10-15%, I will write more about specifik settings later.
commented by (10 points)
edited by

OK, XP 11.11, really rocks now.

I am using the latest nvidia drivers 390.65. and all is done done with my i5 7600K OC 4.8 ghz ang 16 gb ram at 3200 mhz, so no need for extra ram or change CPU ;-)

I am using default scenery with no addons, 

XP11.11 graphic settings on both copys of XP 11 are like this.

Visual effects: High (HDR)

Textture Quality: Max (No compression)

Anti aliasing: 2*SSAA+FXAA

Number of world objects: one stop before high.

Refelction detail: all way down (cant see any reason to use it)

Draw shadow on scenery: off

Vsync: off

allow windshield effects. off (on makes no difference in fps)

I am not using any AI aircraft yet.

I now got 30 fps smooth and stable on both instances of xp11, yeah I am really running all 3+2 monitors + one 7" with garmin 530 pop out, this i really amazing on pretty high graphics settings.

Did the following. 

Open Nvidia control panel.

goto manage 3d settings

Global settings:

changed power managment mode to "prefer maximum performance.

Program settings:

( i have set the following on both XP11-1.exe + xp 11-2.exe)

open gl renderer: for XP11-1.exe (gtx 1060)  and for xp 11-2.exe (gtx 1050ti)

Tripple buffering: on

Vertical sync: adaptive (half refresh rate) = 30 fps.

this did the job, great improvement in fps and lower utilisation off the CPU... wow.

Utilisation on running both xp11 installations.

CPU = 80-90%

GTX 1060 = 70- 90%

GTX 1050ti = 40-60%

this is measured in flying around and over Copenhagen in Denmark  EKCH where i live.

Happy flying and many thanks to you Robert, your support was top dollar ;-)

commented by (22 points)
OK Jonas, thanks for those settings.  I'll follow up on that, but in a few days or os.

Weather has gotten better, so time for some real flying now.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...