0 votes
asked by (12 points)
X-Plane 11 Installer (the demo) crashes immediately on launch. Blank black window with title "X-System", and a system dialog that says "X-Plane 11 Installer.exe has stopped working."

This is a 3GHz Core i5 system running Windows 8.1 (64 bit).

I see some system information in the installer log file, but nothing that clearly indicates a problem. It shows OpenGL Version   : 4.2.0 - Build 10.18.10.3262.

Thanks!

1 Answer

0 votes
answered by (19.3k points)

Attach a copy of the entire installer log.txt document from the desktop. A dump file may also be helpful. You can get one by:

  1. When X-Plane freezes or stops responding, note what the message is above the loading bar.
  2. Open the Task Manager. (Ctr + alt + delete will bring up a list with this option.)
  3. Find the X-Plane program in the list.
  4. Right click on it and pick the option to "create dump file"
  5. When it's done, the pop up will list the file location.
  6. Navigate to the file location in the file explorer window. (It's possible one of the folders in the file path will be hidden. Follow directions here to show hidden files, if needed.)
  7. Dump files are very large so you may need to compress & upload it to a service like Google Drive or Dropbox, then use the share link.
commented by (12 points)
The installer log file and the dump file can be found here:

https://drive.google.com/drive/folders/0B148DKDTxjnkNi1RN25FcjlfSkE?usp=sharing
commented by (19.3k points)
The log shows you are using an Intel GPU. It meets our system requirements, but I wanted to double check that this is what you expected--Sometimes people see a problem with X-Plane using the wrong GPU if there are two in their computer (laptop users especially).
commented by (12 points)
Thanks jroberts. This is a very straightforward system -- just the on-board video, no additional video cards, so I believe there's only one GPU.  HP Envy tower.
commented by (12 points)
I could try installing a video card -- any chance that would help?
commented by (19.3k points)
If you have one lying around you could try it, but I would not advise buying one in case it didn't help and then you wasted your money. I have filed a bug report with links to the info provided.
commented by (19.3k points)
The driver listed in the log appears to be from March 2015. Any chance there's been an update since then you could try to see if it helps?

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...