0 votes
asked by (12 points)
I am experiencing frame rates of around 20fps with a reasonably high-end system in 1920x1080 resolution. I find these frame rates well below expectation. Setting all sliders to left/off gets me up to 60fps, but who wants to use it that way?  I switched off all plugins and am using default scenery only for the test.

Specs:

- Intel Z270i motherboard

- Intel i7-7700 CPU @ 3.6GHz

- 32GB DDR4 RAM

- 512GB Samsung M.2 SSD

- 8TB USB3 external drive for custom scenery with orthophotos (not used in framerate test)

- Nvidia GeFroce GTX 1080Ti

I have switched off the hypertrheading feature for the 1080Ti.

 

With sliders set to 3/4 of the way, I should still be getting WELL over 20fps, no?

What am I missing?  Thx!

1 Answer

0 votes
answered by (19.1k points)

We consider between 25-30 fps the ideal range to shoot for. Highly detailed add ons (scenery, aircraft, etc) can greatly affect frame rate, as can clouds and AI aircraft. You can be bottlenecked on either the CPU or GPU, and depending on which one is your limiting factor, that affects how high certain sliders can be set. Some are cumulative, such as the world objects slider + basically everything else. The more objects you have, the more work the sim does to draw them with detail, shadows, reflections, etc. 

Recommended steps for methodically figuring out the best slider settings for your system can be read here or watched here.

commented by (12 points)
I started with a completely fresh install of X-Plane 11.01, with no add-ons or plugins installed. I followed the instructions to make sure I had the default settings and then ran the tests in 1920x1080 resolution, full screen (on a 3440x1440 monitor). Got these frame rates:

1: 80.47

2: 74.91

3: 66.57

4: 38.69

5: 30.11

6: 37.84

 

Given that my graphics card is pretty much top of the line, I expected better. Is it safe to conclude that I am CPU bound with a 3.6GHz i7-7700?

One other question: in the first 2 tests I see weird little "dots" on the landscape (almost like "static"). Is that meant to be that way?

Thanks!
commented by (19.1k points)
Black dots were a known issue that are fixed in the 11.02 update. I think there  might have been additional frame rate improvements in this update as well, but 11.10 should have even more. Our goal is to get good frame rates (at least 60) with moderate settings in order to accommodate VR in X-Plane 11.
commented by (12 points)
OK thank you. Looking forward to future updates.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...