This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (24 points)
Heading off 90 or more degrees from heading bug setting. Nav not holding course. Some AC engines quitting with plenty of fuel and failures off. Happened on the Carenado C90 and the C208.
commented by (472 points)
Bugs in either the X Plane Beta update or the AC itself could have a bug?
commented by (24 points)
All worked great before Beta update. Hopefully a resolution by Carenado will come.
commented by (24 points)
I'm having the same problem with the B1900D ,latest beta does not fix it.
commented by (24 points)
Haven't tried any of the Beech aircraft yet, I have the C90, B200 and B1900D. I'll try those. Only tried the Cessna 208.  Probably should have held off on solved until I see if those work. Had issue also of engines quiting even with failures off and tanks full including auxiliary which drain first. That was on the C90 and B200 from Carenado.  I'll  let you know on those later.

1 Answer

0 votes
answered by (24 points)
Last update for Xplane resolved issue with heading selector issue. Thanks
commented by (24 points)
Last update resolved heading and NAV issue for Carenado C208 and C90 but the Carenado 1900D still will not track heading or navigation. Heading still off about 65-90 degrees from heading set. Haven't tried the Beech 200 king air yet. Its strange how the Beech AC all use the same autopilot but the C90 worked okay. Will update on the King Air. This is time consuming, Haven't even tried the Seneca V HD or 500Shrike yet.
commented by (24 points)
Update on Carenado B200 Kingair XP 11 edition as are all of my Carenado AC. Same issue with Heading and NAV. Both track 90 degrees to left of setting or course. Strange though how the Beech C90 works even though it has same autopilot as the other Beech AC.
commented by (24 points)
Now after going back to the Carenado Beech C90 it now doesnt work again. Wish I never installed this damn Beta upgrade. Trying to get through ratings on Pilot Edge and these are my go to AC since they used to function so well. Something must have happened after loading the other AC since I just did a flight in the C90 earlier today from Van Nuys to John Wayne without any issues.
commented by (24 points)
Okay, here I go again. Since there is an issue with the heading and nav I figure it had to be an issue with vacuum DG. One thing I noticed soon after the beta update was the Heading on the stock C172 was off its heading. It has a knob to reset it to the correct heading. The left knob on the heading selector. Most other AC dont have it. Somehow the directional Gyros are off. I went into settings then under KEYBOARD to Navigation & Radios, scroll down to Indicators. Near the bottom of the list there is a setting -- vacuum DG sync to north. I created a key command Shift + \. This solved the issue on the Carenado C90. Use any key command you want. Shift\ wasn't assigned to anything else. I put the mag heading on my data output so I can reference  it to the flight instruments. Hope this works in the other Carenado Beech AC. too late for me now. Will try it tomorrow.
commented by (16 points)
Thank you!  This keyboard command corrected my issue.  When autopilot is engaged, there was a 60 degree difference in the heading bug and the resulting coarse being flown.  The aircraft is a Carenado King Air c90b.  The key is (under Navigation & Radios/Indicators) Vacuum DG Sync to Magnetic North.  Thanks again.
commented by (95 points)

Here below the answer of Carenado support for this kind of issue

"X-Plane now automatically randomizes the gyro drift when starting from cold and dark. Here are two ways to work around it for now:

A) Assign a keyboard key or joystick button to Nav & Radios --> Indicators --> "vacuum DG sync to magnetic north". Simply press that key or button after the plane has loaded, and that should sync the gyro drift.

B) Alternately, you can edit the aircraft's .acf file to permanently fix this (we'll release this fix in an upcoming version) :
0. Make a backup of the plane.
1. Open the "Car_B200.acf" file in a simple text editor like "Notepad++" for Windows, or "Text Wrangler" or "BBEdit" for Mac.

2. Search for "P acf/_otto_ah_source_type". You should find two lines, like this:
P acf/_otto_ah_source_type 12
P acf/_otto_dg_source_type 12

3. Change the "12" at the end of both lines to "11", like this:

P acf/_otto_ah_source_type 11
P acf/_otto_dg_source_type 11

4. Save the file.

Now when you load the plane in XP11.10, the autopilot should follow the HSI, no matter what the vacuum drift dataref says. This same fix should also work on other planes that end up having this issue."



commented by (24 points)
What program opens an .act file. I tried modifying the PC12 acf because of the ITT temp issue but the file wouldn't work. I used corel word perfect but it wouldn't save as an .acf.  can't open with default windows stuff
commented by (24 points)
Never mind I saw your recommended programs. Thanks