0 votes
asked by (443 points)

When I launch X-Plane (version 10.03) I get an error dialog box that says:

X-Plane cannot access 3GB of virtual memory. This can cause crashes and memory shortages with high rendering settings.

Clicking "Understood" launches X-Plane 10, but after a few seconds of loading, the program freezes, and Windows Task Manager says X-Plane 10 is not responding.

I'm running Windows XP Pro, with 4 GB of RAM, and a Radeon HD 5770 1GB video card. I have all the latest Windows updates, and X-Plane 9 works like a charm.

2 Answers

0 votes
answered by
selected by
 
Best answer

I take it your dialog box looks like this?

There are options for increasing the available virtual memory on Windows XP (like this), but honestly, I don't recommend them.

Your best bet is to upgrade to a 64-bit operating system (I suggest Windows 7 or Windows 10) and run the 64-bit version of X-Plane. Under those conditions, this issue should go away entirely.

0 votes
answered by (76 points)
edited by

I had the Exact Same Problem.

First and Foremost - this is a Problem of Terminology.  X-Plane is coded in the MAC Environment - maybe the term  "Virtual Memory" in that realm is probably defined and used that way. 

But In Windows Nomenclature - you are Not running out of Virtual Memory.   In the Windows World, Virtual Memory is the Page (or Swap) File located on a HDD or SSD (Storage). Is has nothing (really) to do with (RAM) Memory.    Virtual Memory is indeed used as a Poor Man's Substitute when your PC runs out of real Memory.  It caches data that would normally reside in real Memory and has to (slowly) swap that information to the CPU.   Virtual Memory (Swap File) is 100s of times slower process than real RAM communicating with the CPU.

What you are short on is Addressable (Memory) Address Space (Explained Below).   Simply - this is the division of what Windows takes for itself, and what it allows for Applications to use.  Even though you have 4GB of Memory, Windows is not allocating enough to X-Plane 10 for it to Fly.  Windows XP is hogging it.  To adjust for X-Plane 10, you must Boot with the " /3GB" Switch.

I can (but no longer do) fly X-Plane 10 on my vintage 2009 PC using Windows XP Pro 32bit Version.   By using the " /3GB' Switch in the Boot.ini File - X-Plane 10 (X-Plane32bit.exe) will Fly !

Here is an example of my Boot.ini (will give you the option to Boot Normally, or Boot into Windows with " /3GB" Switch:

=================================================================

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptOut
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional with /3GB Switch" /fastdetect /NoExecute=OptOut /3GB

===================================================================

Applicable Articles to help understand your Problem:

Increasing Virtual Memory on Windows
http://www.x-plane.com/?article=increasing-virtual-memory-on-windows

Configuring X-Plane to Use Less Virtual Memory
http://www.x-plane.com/?article=configuring-x-plane-to-use-less-virtual-memory

3GB Switch in Windows boot.ini
http://www.maxi-pedia.com/3GB+switch+Windows+boot.ini+3+GB

 

 

BOL,

Igor4U !

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...