0 votes
asked by (12 points)
Since I upgraded X Plane from 11.30 to 11.31 when using the Hot Start TMB 900 aircraft X Plane shuts down when trying to set up a flight plan. Cannot fly anymore. It was perfect with X Plane 11.30

Any suggestions to fix this problem.

Thank You

2 Answers

0 votes
answered by (3.8k points)

In the first instance attach your log.txt file.  Refer to the advice provided in the following link found at  https://questions.x-plane.com/23135/frame-rate-slow

commented by (10 points)

Same problem here. Since installing 11.31.

Since it is also possible to enter a flightplan into the TBM900 FMS by entering a plan into 124thATC,  I tried that and that works. But if I delete that flightplan and try to manually enter a flightplan int the FMS again, Xplane crashes. Below is (part of, due to character limitation of the forum) the logfile of that crash.

Also, here is some text from the TBM logfile that may hint that there is a problem with the updated earth_nav.dat  :

\X-Plane 11\\Custom Scenery\Global Airports\Earth nav data\earth_nav.dat: malformed data on line 1051

2019-02-04 11:19:46 TBM900[navaiddb.c:512]: Error parsing C:\Users\Peter\Desktop\X-Plane 11\\Custom Scenery\Global Airports\Earth nav data\earth_nav.dat: malformed data on line 2000

2019-02-04 11:19:46 TBM900[navaiddb.c:512]: Error parsing C:\Users\Peter\Desktop\X-Plane 11\\Custom Scenery\Global Airports\Earth nav data\earth_nav.dat: malformed data on line 2011

(This goes on for many more lines)

log.txt for X-Plane 11.31r1 (build 113100 64-bit)
 compiled on Jan 24 2019 22:17:18
X-Plane started on Mon Feb  4 10:55:35 2019

This log file is generated automatically by Laminar Research applications and contains diagnostics about your graphics hardware, installation, and any error conditions.
If you need to contact tech support or file a bug, please send us this file. NOTE: this file is rewritten every time you start ANY of your X-System applications.

Windows 10.0 (build 17134/2)
This is a 64-bit version of Windows.
CPU type: 8664
Physical Memory (total for computer): 17118986240
Maximum Virtual Memory (for X-Plane only): 140737488224256
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600
CPU 0: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz  Speed (mhz): 3600


124thATC v2.0-a59 11:01:08 : Entering FMS Programming (processing 3 fixes)
124thATC v2.0-a59 11:01:08 : FMS cleared, entries now: 0
2019-02-04 11:09:02 TBM900[efis.c:2018]: assertion "ref != -1" failed:
Backtrace is:
0 0000000080030CB2 C:\Users\Peter\Desktop\X-Plane 11\Aircraft\X-Aviation\TBM-900\plugins\systems\win_x64\systems.xpl+40cb2 (efis_get_dest+a2)
1 00000000800C1E66 C:\Users\Peter\Desktop\X-Plane 11\Aircraft\X-Aviation\TBM-900\plugins\systems\win_x64\systems.xpl+d1e66 (taws_floop_cb+1f6)
2 00000000800CDC11 C:\Users\Peter\Desktop\X-Plane 11\Aircraft\X-Aviation\TBM-900\plugins\systems\win_x64\systems.xpl+ddc11 (main_floop_cb+7a1)
3 00007FFF77405202 C:\Users\Peter\Desktop\X-Plane 11\Resources\plugins\XPLM_64.dll+15202 ()
4 00007FFF773FB374 C:\Users\Peter\Desktop\X-Plane 11\Resources\plugins\XPLM_64.dll+b374 ()
5 00007FF61D5D48B4 C:\Users\Peter\Desktop\X-Plane 11\X-Plane.exe+a248b4 ()
6 00007FF61CC889B9 C:\Users\Peter\Desktop\X-Plane 11\X-Plane.exe+d89b9 ()
7 00007FF61D01311A C:\Users\Peter\Desktop\X-Plane 11\X-Plane.exe+46311a ()
8 00007FF61D880D87 C:\Users\Peter\Desktop\X-Plane 11\X-Plane.exe+cd0d87 ()
9 00007FF61CC8BAFC C:\Users\Peter\Desktop\X-Plane 11\X-Plane.exe+dbafc ()
10 00007FF61DA9FBC7 C:\Users\Peter\Desktop\X-Plane 11\X-Plane.exe+eefbc7 ()
11 00007FFF99113034 C:\WINDOWS\System32\KERNEL32.DLL+13034 ()
12 00007FFF9A1F3691 C:\WINDOWS\SYSTEM32\ntdll.dll+73691 ()

0 votes
answered by (14 points)
I have exactly the same problem.

It can be reproduced on my machine by simply entering a flight plan. It always crash when I tried to load an ARRIVAL route in the flight plan. XPlane does not crash to desktop, but the GUI just freezes, ALL keys do not work except the Ctrl-Alt-Del combination. The only way to exit the stuck Xplane with TBM900 loaded is to kill the XPlane process from the Windows Task Manager.

XPlane 11.31

HotStart TBM900 v1.1.4

XEnviro 1.0.9s

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...