0 votes
asked by (18 points)

Hi,

Just installed a new Nvidia 970 GTX graphic card upgrading from a 670 GTX and have not yet adjusted any rendering options. After about 30 minutes of running XP10.45 the program crashes with a black screen and I get this message:

I also use P3D and do not have an issue at all or any other software that I use. I have the latest driver for the 970.

CPU: i7-3770K @ 3.50 GHz

GPU: Nvidia Geforce GTX 970 4096 MB

I would be much obliged if you could point me in the right direction to resolve this issue.

I've included my latest Log file.

imageDownload file

Regards.

1 Answer

0 votes
answered by (594 points)
edited by
Good day,

I have a similar CPU and I have the same card as you, a GTX 970 with 4 gb VRAM. I have the same issue as you but I get Display Driver errors, Kernal Errors, and TDR's errors even though I changed it in the registry folder. If you are running Windows 7, I believe 347.88 fixes the issue. I got 10, so I stuck with the error even though I've tried all the drivers. You also could go into Nvidia control panel and change power management mode to Maximum Performance Mode. I believe this is a Nvidia problem-all their drivers are broken in some way.

Let me know if this solves your issue

-Rishi
commented by (10 points)
I tried this and it's still giving me the same problem.
commented by (594 points)
edited by
Any chance that you can go back to Win 7 or are stuck with 10. When I was with Win 7, 347.88 solved the issue but in 10, that driver isn't there. There are numerous requests for Nvidia to release a patch but they aren't listening for some odd reason. They are continuing to release broken drivers. I've had the problem for 7 months now and it's ruining my XP experience. I'm slowly going back to FSX cuz of this. It isn't an XP related issue, a Nvidia driver related issue. You could file a bug report to the developers of XP to see if they can do anything but I doubt that would help.

https://m.youtube.com/watch?v=M1GN7UB6zX0

Go to the end of the video and he goes through the setting of Nvidia Control Panel. I tried this but with no luck. I'm not sure about you :)

-Rishi
commented by (10 points)
The video worked for me, just put the settings in and I rolled back my driver to .39. MAKE SURE you do it for X-Plane and not global settings.  My X plane works like a charm.
commented by (594 points)
Glad that worked out for you

-Rishi
commented by (594 points)
Wait what driver did you use?

-Rishi

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...