0 votes
asked by (12 points)
Two X-Plane 10 systems running version 10.5. Side by side.

System 1 is i7-6700K overclocked to 4.5GHz, multithreading on, running Windows 10 anniversary edition. Graphics card GTX 980, 32GB memory. (Established system on X-Plane 10 for some time with regular updates)

System 2 is i7-6850K overclocked to 4.4GHz, multithreading off, running windows 10 anniversary edition. Graphics Card GTX 1080, 64GB memory. (Newly built system, recently installed digital download X-Plane 10)

Rendering settings set up the same, same scenario, plane, airport. Disabled plugins on first system to match the basic installed second system.

The issue is that my frame rates are 10-20 fps worse on the second system than the first. To the point of below 20fps at more times than it should compared to the same scenario on system1. This makes X-Plane and me very unhappy when flying.

The video card on system 1 (GTX 980) is running about 90% utilized. On the second system (GTX 1080) it is about 45-50%.

What is strange is that when I look at the two systems via HWMonitor, the 4 cores on the first system are pegged close to the overclocked max (4.5GHz) while running x-plane. On the second system the 6 cores vary a lot from maxed clock (4.4GHz) to 1.2GHz. One theory is that X-plane not getting enough processor time or not forcing the cores to clock up to higher frequencies consistently like the 6700K. I am at a loss as to why it would it be treated differently on the 6700K vs the 6850K. I've tried to increase the priority of X-plane 10 in task manager to high, but no positive change to X-Plane.. Any thoughts, ideas or help would be appreciated.

1 Answer

0 votes
answered by (19.3k points)

I assume these computers are networked together to show the same flight. If that is true, please file a bug report here. We are tracking an issue related to jerky external visuals on networked computers. 

commented by (12 points)
Hi thanks for the quick response. No they are standalone. I did have them networked as my original intention was to have the 6850K be my primary and the 6700K my slave. I did notice some jerky visuals and at one point i got a weird error where it said access to my graphics card was being blocked. That is along the lines of your inquiry, but a bit off topic from my original question but wanted to provide you feedback that i have experienced the jerkiness when networked.

The main issue is why the performance on my second computer, both standalone, was far worse than my first computer. They are overclocked to similar frequencies and why in particular the 6850K machine's cores were not being pegged to the overclocked frequencies like was happening on my 6700K machine. I don't know what is different for X-Plane running on the 6700K and X-Plane running on the 6850K that would cause this. Maybe i'm missing a tweak to make the second machine work like the first?
commented by (866 points)
This is potentially an issue with your Windows 10 Anniversary edition. There have already been multiple reports of major FPS drops since the Anniversary update. See this: http://www.x-plane.com/kb/frame-rate-issues-windows-10/

Another solution would be to try and update all of your graphics drivers (for your two cards). Good luck!
commented by (19.3k points)

X-Plane does not recognize overclocking. For more information you might find this question/response interesting.

commented by (12 points)
hi Jroberts and JoeFlyer15, thanks for your responses.  To Jroberts, the link is to GPU overclocking and i am not sure if that applies here as i have not overclocked my GPU. The CPUs on both systems are overclocked and all that means is that the code supplied to the CPUs runs faster. I don't think X-plane would have anything to do with the overclockability of the CPUs themselves. My question is that on my 6770K machine the CPUs are running at frequencies close to their max oveclocks on all 4 cores when x-plane is running. On the 6850K it is all over the place. I was just wondering why that would be.

To JoeFlyer15, thanks for the info, i did check it out and i did turn off DVR capture as suggested in the post. It did not however change the situation for my 6850K machine. It still is running at lower frame rates than the 6770K. I am starting to thing it is something to do with the scheduling of software on the 6850K vs the way it is done on 6770K. I am just surprised that there would be that much difference between the two. Thanks to you both for your responses.
commented by (12 points)
I explored my scheduling hunch and found out how to set the affinity mask for the application running in Task manager. If I limit X-plane to 4 cores in task manager, then for some strange reason it clocks up all the 6 core frequencies to close to the 4.4Ghz overclock i have on the 6850K as shown in HWMonitor. This behavior is exactly like the 4 core 6700K i noticed on my other machine. The FPS when running X-plane also increases on the 6850K to similar rates to the 6700K, minor differences due to the 6700K having a 100Mhz overclock advantage.  I have no explanation as to why X-plane operates like this when limited to 4 cores as opposed to 6 cores when there is no limit on the application. Any words of wisdom from anyone would be appreciated, but as far as having a better running X-plane on a 6850K the trick for me is to limit the number of cores it is run on. I may check what happens if I drop it to 3 or 2 cores.
commented by (866 points)
This is indeed interesting; perhaps it was a problem with X-Plane 10 core utilization? I understand that X-Plane 11 will be manipulating the cores in a more advantageous way (I think) than X-Plane 10 did/does.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...