0 votes
asked by (23 points)
When I switch to full screen display, the mouse cursor disappears, making it virtually impossible to use the menus or click on cockpit controls. The mouse does still function, but the cursor cannot be seen, so you have to guess about where to click. The cursor appears normal when in windowed display mode. Has anyone else had this problem, and is there a fix or workaround? I'd like to be able to use full screen, but this problem makes it impossible.

2 Answers

+2 votes
answered by (23 points)
 
Best answer
Randy Witt at X-Plane customer support gave me the answer to this problem. I had the mouse trails option turned on in Windows. I turned that option off through the Windows control panel, and now the mouse is visible in full-screen mode. Thank you, Randy!
0 votes
answered by (19.3k points)
I tried checking full screen on my iMac running OSX 10.11.1 & X-Plane 10.45b1. My mouse cursor did not disappear. Can you upload a copy of your log.txt and expand on what type of set up you are using?
commented by (23 points)

I am running the demo version of x-plane, version 10.42 build 104200 64-bit. I am using Windows 10 with a 3.2 GHz CPU and 12 GB RAM. My video card is NVidia GeForce GTX 750 Ti with 2 GB video memory.

The log.txt file is attached from a session in which I opened x-plane in windowed mode, switched to full-screen, and then switched back to windowed before closing the program.

I switched to full-screen by going into the Settings menu > Rendering options, then checking the box for "run full screen at this resolution". The screen resolution is set to "Default Monitor Settings".

The mouse cursor disappears as soon as it goes into full screen mode. If I move the mouse at random and it happens to fall onto a button or control that changes the appearance of the cursor, I can see the changed cursor shape, but as soon as it moves off of that control, it disappears again. I can ctrl-Tab to bring a different program (e.g. windows explorer) to the foreground in front of the x-plane screen, and then the cursor becomes visible. But as soon as I click on the x-plane screen, giving it the focus, the cursor disappears again.

I'm wondering if anyone else running x-plane in Windows 10 can reproduce this issue.

 

commented by (19.3k points)
I also tried this on a Windows 10 PC with a Nvidia GPU. I did not lose the cursor when I selected full screen in either the demo or full version. Can you attach a screenshot of your rendering settings? Maybe it only happens with specific options selected. I used the default High ren preset.
commented by (23 points)

Thank you for responding. Here is a screenshot of my rendering settings. I also tried it with the High preset, and the cursor still disappeared. I tried changing some of my Windows display settings too, but couldn't find anything that made a difference.

 

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...