0 votes
asked by (13 points)
I'm having trouble using the left and right keys to look around the cockpit (i.e. the "general/left" and "general/right"). for some reason they don't work for me in any aircraft.  

Other similar features still work such as "general/zoom_in" and "general/zoom_out" (=, -) and "general/up" and "general/down" (up / down arrow keys) even "general/rot_left" and "general/rot_right" (q and e) work. But for some reason the "general/left" and "general/right" function does not work. Interestingly, the "general/rot_down" and "general/rot_up" (f and r) don't work either.

I've recently installed X-Plane 10.45 on a Mac

Thanks for your help

1 Answer

+1 vote
answered by (19.3k points)
It sounds like the default key bindings have gotten changed. You can check under the Joystick & Equipment -> keys tab to see your key assignments. You can also delete the preferences to have X-Plane restore the defaults on the next start up. I believe deleting only X-Plane Keys.prf will restore default key bindings.
commented by (13 points)
Thanks for the suggestion jroberts. I did check to ensure the keys were programmed correctly in the Joystick & Equipment panel and I even went to the extent of deleting the individual left and right keys and reprogramming them.

I took your suggestion and deleted the key.prf file and it seems to have restored the default settings / keys, however my issues still exists, the left and right arrow keys still do not move my view like the up and down arrows do. This is very annoying as I can't zoom in on the MFD on the Garmin G1000 on the Cirrus SR20 I purchased :(

PS I can confirm that these keys on my machine do in fact work in other software applications ;)
commented by (19.3k points)
What view are you using? The left & right arrow keys don't work with the 2D panel, which is often the default view. Even if it looks like a 3D panel, you may still need to tell X-Plane to use that view by pressing shift + 9. (You can try changing the default panel view setting in the rendering options screen if the all the aircraft you use have 3D panels .)
commented by (13 points)
Perfect. Thanks. That's the thing I was missing, that the left and right arrows weren't meant to work in 2D setting. I've set 3D to default and all good. Thanks for your help.

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...