This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (12 points)

I am new to x-plane 11 and am running it on the following windows 10 64 bit system:

Intel i7-9700k
Gigabyte Z370 Aorus Ultra Gaming 2.0 motherboard
16GB Gskill DDR4 2666.8 Mhz RAM
Nvidea GeForce RTX 2070 OC 8GB graphics

My monitor is an MSI Optic AG32CQ running on a resolution of 2560x1440 @1444hz

I hoped that my system would allow me to use x-plane 11 on high graphics settings, however no matter if the graphics settings are set to maximum settings or minimum settings, I cannot achieve a frame rate of more than 15, which results in the warning that minimum frame rate has not been achieved.

I have no plugins for the x-plane and my system does not appear to be being taxed by x-plane.

Would welcome any thoughts or advice on how to remedy this issue.


commented by (12 points)
Today, unexpectedly I started X-Plane 11 and loaded the tour of London flight. I immediately saw that I was achieving 30fps on maximum graphic settings. Reloaded a flight for me to fly and the game now appears to be running as expected. Not sure why this seems to have resolved, but it has.

Thanks for all the comments and suggestions.

3 Answers

0 votes
answered by (2.2k points)

Hi Macvoon3

I'm just another simmer in the UK, but the short answer must be yes, you should be getting way higher than 15fps with that RTX graphics card & CPU!

My system comprises Windows 10 64bit, i7 8700k CPU @ 3.70 Ghz, Geforce GTX 1070 @ 8GB DDR5, 1TB M2 hard drive & 64 GB Ram and I'm currently getting over 60fps, even flying over True Earth GB terrain.

The only thing that stands out slightly is that your RAM has a lower capacity than mine, so maybe this is something you could look at?

Alternatively, before changing any hardware, go to the following URL and download the free system test tool. Run the test just to see how things are currently, this should advise if there are any issues with your components?

Hope this helps for now


commented by (2.2k points)
PS I should mention that even my frame rate drops momentarily every now and again, but I put this down to the PC working on some other piece of software at the same time I'm using X-Plane 11.

commented by (12 points)
Thank you for replying. I ran the test you recommended and received these results:

UserBenchmarks: Game 115%, Desk 82%, Work 87%
CPU: Intel Core i7-9700K - 113.9%
GPU: Nvidia RTX 2070 - 136.5%
HDD: WD Blue 4TB (2015) - 96.2%
RAM: G.SKILL F4 DDR4 2666 C18 2x8GB - 85.9%
commented by (19 points)
Hello :) I am just another simmer and I thought I would chime in as this is a known issue that he development team is currently working on resolving. There are many users (including me) that are having this issue. The issue presented itself with the latest update (11.30). I hope they will get it fixed soon as it renders the sim useless. I currently have an open ticket with there support team and can update this thread once I have more information.
commented by (12 points)
Hello. Well at least I am not alone with this issue. Would be great if you could update this post if you receive any solutions.
commented by (19 points)
Absolutely I will :) Once a resolution as been made or if anything comes up I will update this thread!

0 votes
answered by (685 points)

Your system should definitely be achieving much higher frame rates than 15.  I have a very similar setup as yours (2070, 1440p, 32GB, a lesser i7), and consistently getting mid 20 or better at just under maximum rendering, depending on scenery, aircraft, weather, AI traffic etc.  16GB of RAM should be good enough under most scenarios, unless you have very high resolution Ortho scenery and many other apps running concurrent to X-Plane.

One thing to make sure is if you have multiple monitors, have them be driven by the same RTX 2070—i.e., don’t enable any integrated graphic hardware.

Like Greengolfer has suggested, use something such as Windows’ Task Manger to check whether the CPU and GPU are getting their expected utilization.

commented by (12 points)
Thanks for replying. No multiple monitors or additional scenery. My version of X-plane is as what you get when you buy it. I will look into the background tasks though.
0 votes
answered by (136 points)
Also check the temperatures of your cpu and gpu. If the cpu temperature is too high thermal throttling can result, in either stopping your cpu to automatically step up frequency (speed) or stepping it down. Similar applies to gpu. I am not certain what your OS is but I use psensor in linux. It gives temperatues, cpu, gpu utilization and fan speeds. In windows core temp or hw monitor are good.
commented by (12 points)
I use NZXT's CAM software that came with their Kraken cooler to monitor CPU and GPU temps, none of which have exceeded 40c.
commented by (685 points)

The GPU at 40oC means it’s hardly working up a sweat.  It seems practically idling!

My RTX 2070 typically runs at 60oC+ when cruising in XP11; 37oC when at rest (no 3D activity).  And the GPU Load can also be a telltale sign (see Task Manager).  In clouds, I’ve seen it approached 100%.

commented by (136 points)
As mentioned by disc your cpu and gpu are almost idling. You could try turning on Threaded optimization for X-Plane in Nvidia settings. Before 11.30 the advice was to turn it off but after, it can benefit to turn it on. Also try turning off power savings in your OS.