This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (47 points)

When I start automatically on the runway and I take off, all is good and Auto Pilot enables well and I am able to do my flight

THE ISSUE: when I taxi from gate to the runway and take off, once I am in the air the Autopilot does not enable well and the plane starts turning madly and then crashes

How do I take off after having taxied from the gate, and succesfully enable autopilot?

1 Answer

0 votes
answered by (19.3k points)

If you follow the exact same procedure to enable the autopilot after taking off from the runway as you do when you taxi to the runway then take off, but you notice different behavior, that seems very odd to me. If that is the case (exact same steps on your part, different autopilot behavior) it could be some sort of bug. Please file a bug report here and include your exact, step by step instructions to see the issue. (Please make sure you are using only default planes and scenery.)

commented by (47 points)
could it be linked to 'bad taxiing' ? When you taxi do you use autopilot or control with the joystick?
commented by (19.3k points)
In real life I think pilots only ever engage the autopilot after takeoff, possibly while climbing to altitude. If you're trying to use the autopilot to taxi, you may definitely be seeing it use bad routes. Or are you trying to use the "AI flies my plane feature"? A lot of AI movement depends on having hand drawn taxi routes at the airport. If the airport has a default taxi route, all bets at sane movement are off--those routes are bizarre.
commented by (594 points)
Pilots don't enable the autopilot while they taxi. That might be causing the issue you're having- trying enabling the autopilot once you leave the ground.
commented by (47 points)
I don't usually enable AP when on ground , my problem is the AP enabling when I take off. I taxi to the runway using my joystick. Thank you anyways guys, will try again once I travel back home