This site is being deprecated.

Please see the official X‑Plane Support page for help.

+1 vote
asked by (32 points)

Hi, X-Plane dev-s :)

I'm so glad to see now that finally you had optimized and fixed low-performance in X-plane 11. Very nice job, thx.
Now having:
GTX 970 4 GB and intel i5 3.5 ghz with 8 GB RAM i have 30 fps outside an any plane on high settings (close to ultra).

But i still have low fps in 3d Cockpit (It's also better than in releases which you made before, but still around 15-20 fps), so i think you can improve framerate in cockpit too.

Despite this, now generally we have good optimization. So thanks to LR! 

1 Answer

0 votes
answered by (1.8k points)
You can also try turning off threading optimisation.