0 votes
asked by (63 points)
I cannot get my Thrustmaster Rudder Pedals to configure correctly on XP11, due to there being no rudder right and rudder left axis' (like in XP 10) that I'm aware of. There only a single yaw axis, which cannot be applied to both pedals at the same time.

Does anyone know what I may be doing wrong/missing?

Thanks!

3 Answers

0 votes
answered by (19.3k points)
My understanding of rudder pedals is that Yaw should be set to the axis that moves when you move both pedals back and forth. Pushing each pedal down separately should be set to toe brakes left/right.
0 votes
answered by (14 points)
I'm afraid X-Plane 11 beta is not suited yet for working with these pedals for now. I have and many people have calibration problems. Yaw works ok but when you activate the brake function it freezes the plane in a unreversable way. Let's hope that final version will solve this problem but...
commented by (40 points)
On 01-09-17 I switched out my MFG Crosswinds Rudder pedals for a new pair of the Thrustmaster flight rudder pedals. I was having Xplane 11 crash and send error reports and I also got a message from the Xplane program that advised me to recalibrate my Crosswind's dead zones or something... the TM rudder pedals also match my warthog so I wanted to try them with everything that was happening. I uninstalled my current Thrustmaster software after downloading Thrustmaster's latest software, looked like it was updated around December 2016. I unplugged my warthog. Installed this approximate 40 meg TM update. The update also had this cool Target script editor and Target GUI software that let me adjust the lights on my warthogs throttle. But after plugging my equipment back in after updating from Thrustmaster, I then re-calibrated with my windows 10 and then re-calibrated with Xplane 11 and I have better control taking off with the runway and everything on my end is working perfect for a Beta 11. I have so far had no Xplane 11 program crashes. I did notice my brakes in calibrating with Xplane 11 showed reverse, so I clicked on reverse by putting a check in that box that then made the brakes light up on that blue strip when I step on the brakes for stopping power as opposed to it all being lit up blue and stepping on the brakes to have the blue strip come back down. Hope that was understandable.   Xplane 11 manual states that it will most likely work best on a PC that is newer. It further advises that PCs that are 24 to 36 months old might want to back off on settings.  I have a new PC with a i7 8 core plasma cooled CPU. 32 gigs of RAM. Gforce 980TI. I am running Xplane all maxed out. It looks hot! My warthog is working perfectly on my end for a beta I can't see any problems. Try and update your Thrustmaster software.

Try this link. This is where I was last night. I only installed the software, not the drivers.

https://support.thrustmaster.com/en/product/tfrp-en/

 

DragonFlySlayer
commented by (40 points)
Milan from Crosswinds.com  helped my dumb ass calibrate my Crosswinds properly with the Configurator v2.15 so now it is finally smooth.  So since I paid mega bucks for the dam things I am using them and happy with the feel!  My Thrustmaster Rudder pedals went back in their box and up in the closet as they are still keepers!.  They still worked flawlessly though in Xplane 11 Global Beta.  The new TM Update Target Script editor still works great also with the Warthog stick/throttle.

I'm thinking that most pilot's troubles may have come from needing a TM update?
0 votes
answered by (40 points)

On 01-09-17 I switched out my MFG Crosswinds Rudder pedals for a new pair of the Thrustmaster flight rudder pedals. I was having Xplane 11 crash and send error reports and I also got a message from the Xplane program that advised me to recalibrate my Crosswind's dead zones or something... the TM rudder pedals also match my warthog so I wanted to try them with everything that was happening. I uninstalled my current Thrustmaster software after downloading Thrustmaster's latest software, looked like it was updated around December 2016. I unplugged my warthog. Installed this approximate 40 meg TM update. The update also had this cool Target script editor and Target GUI software that let me adjust the lights on my warthogs throttle. But after plugging my equipment back in after updating from Thrustmaster, I then re-calibrated with my windows 10 and then re-calibrated with Xplane 11 and I have better control taking off with the runway and everything on my end is working perfect for a Beta 11. I have so far had no Xplane 11 program crashes. I did notice my brakes in calibrating with Xplane 11 showed reverse, so I clicked on reverse by putting a check in that box that then made the brakes light up on that blue strip when I step on the brakes for stopping power as opposed to it all being lit up blue and stepping on the brakes to have the blue strip come back down. Hope that was understandable.   Xplane 11 manual states that it will most likely work best on a PC that is newer. It further advises that PCs that are 24 to 36 months old might want to back off on settings.  I have a new PC with a i7 8 core plasma cooled CPU. 32 gigs of RAM. Gforce 980TI. I am running Xplane all maxed out. It looks hot! My warthog is working perfectly on my end for a beta I can't see any problems. Try and update your Thrustmaster software.

Try this link. This is where I was last night. I only installed the software, not the drivers.

https://support.thrustmaster.com/en/product/tfrp-en/

 

DragonFlySlayer

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...