This site is being deprecated.

Please see the official X‑Plane Support page for help.

0 votes
asked by (16 points)
Upgraded from Gtx 770 to Nitro rx480. (Big performance improvement in P3d v3.4.)

[ I7 980 - rampage formula 3 + 24gb - ssd drives x 2 - win 10 x 64]

X-plane 10.51 and x-plane 11b13 do not like the Nitro.

On screen fps meter:   (actual 13, in sim 19).   Does not  help if I turn down the  graphics settings to bare minimums.  I get no increase in frame rates whatsoever.  I am a P3d convert as of x-plane 10.

In order to enjoy the x-plane experience I reinstalled my 770.  Waiting for the day that I can put the Nitro back in my machine.  BTW: the rendering of textures etc seems so much sharper vibrant when using the Nitro.

Please advise

2 Answers

0 votes
answered by (570 points)
edited by
Something wrong with your pc... I use i7 4790K@4.6Ghz/ AMD 290X and I get 28 fps with Rotorsim EC-135

Visual effects= Max

Texture= Max

AA= 2xSSAA+FXAA

Draw shodows checked.

Number of objects= Medium

Reflection= Medium

Lateral FOV=100ยบ
0 votes
answered by (3.5k points)

Hi, I think this can be a useful answer, find on http://developer.x-plane.com/2017/10/x-plane-11-10-beta-1-is-here/#comments :

sdancer says:

October 12, 2017 at 2:46 pm

Beta 1 (Demo, didn't bother buying XP11, see blow) now runs at around 9FPS and produces a warning that it runs at <0.5x time-speed when starting a new flight at Seattle. At the same settings, the release version at least managed 17 FPS without the warning, not that it would be "good" or "usable" at either.

This is on a Ryzen 1700 with an RX 480, and I've reported miserable performance in the last few versions of XP10 and the first couple betas of 11 at all quality levels, supplying all the logs the bug reporter asked for. Is it really supposed to run that badly on AMD hardware? Is there anything to change or do to make it at least run semi-acceptably?

Reply

  • Sidney Just says:

    October 12, 2017 at 3:18 pm

    AMD hardware currently runs with quite a few modern optimizations disabled since they lead to hangs on our machines. We have a patch for that in the works, and you can try running the sim with --no_workaround which should make things faster again (although at the cost of stability. If your computer hangs or driver crashes because of the option, please don't file a bug report). The hang is a bit sad since we actually followed the best practices set out by AMD, and they work just fine on Nvidia hardware.

    Reply

    • Steve says:

      October 12, 2017 at 3:59 pm

      Sidney, I'd like to test that --no_workaround option just to see what's possible.

      is the command like this?

      "C:\X-Plane 11\X-Plane.exe--no_workaround

      I'm running an rx480 and i've really no complaints, I've noticed an improvement in 10.10 with frames and general smoothness, I'm using an rx480 8gb with a core i5 4590. 16gb/ram ddr3.

      I get 30FPS with the following settings at KSEA at the default runway location.
      In the default cessna, 3dcockpit view at KSEA
      visual affects - max
      texture quality -max
      antialiasing - 2xssaa+fxaa
      world objects -medium
      reflection detail - min
      shadows on scenery - off

      hope that is some help.

      Reply

      • Sidney Just says:

        October 12, 2017 at 4:12 pm

        You'll need to put a space between the command line argument. So something like: "C:\X-Plane 11\X-Plane.exe" --no_workaround

        (Note that you'll need the quotes around the path if it contains a space). Alternatively you can also create a shortcut to the .exe and then right click on it "Properties" and then add "--no_workaround" (again with a space before the argument) to the "Target" line.

...