+7 votes
asked by (42 points)
edited by
I have a very decent frame rate (60fps) when starting x-plane 10.5. After a few minutes running x-plane this rate drop to single digit for no apparent reason. I run x-plane with all plugin disabled. cloud to min, and setting to medium while i run on 64 bit, 16.0GB RAM - window 10 and a cpu at 3.60hz (window 10).

one note. when i quit app and restart, the frame rate is restored (to around 60 fps) and issue recur. Also... when deleting all x-plane pref file, the issue goes away for a while and re-appear after a while.

 

please help
commented by (10 points)

I have the same issue,  but I also had this in the previous 10.4x version.  I have multiple monitors, but one runs on the onboard adapter and the primary runs on a GTX980 that is in SLI mode.  I seems to happen more often when I click out of xplane to the other screen.  The problem is the timing is not always the same.   But like you,  I start 60-70fps and fail down to 2fps.  I also notice that this failure messes up my Windows start menu making all the icons disappear.  I have already tried uninstalling and performing a clean install of the latest video drivers but that also hasn't changed anything.

I hope there is someone more clever than I to help because at this point the simulator is unusable which is a shame since I am a xplane newbie that is really starting to like the direction the simulator is going. I have attached my log.txt file as I have since this is important.

Regards,
Brett

imageDownload file

 

 

commented by (25 points)
If you're on windows 10 you might wish to uninstall update KB3176938. This is most likely the culprit as it was with many of us.
commented by (10 points)
Denis,

Thank you for your reply,  sadly Windows 10 doesn't know how to count, the cumulative release was installed on Sep 2 but I guess there is some weird 10 day limit you have to uninstall if things don't work.  Today is Sep 11 and Windows 10 is telling me I can't uninstall that update as it's been too long. Hummm 11-2=9 last time I checked.  On a quest to find a way around this M$ roadblock.  Hopefully some of the XPlane folks will see this and find the route cause.

 

Brett
commented by (42 points)
So.. after 2 days of trying everything... 1) un-installed Nvidia driver, re-installed fresh = no change, issue still there. 2) tried an earlier Nvidia driver as some post on other forum suggested = no improvement. 3) cannot roll back microsoft update. Window 10 will not allow - time limit. 5) cleaned window registry - several times = no changes....

What is certain is that 2 screen, 1 computer and x-plane causes issue. Other certainty, by what I see, other games/software are affected but not the one from Microsoft. In short, Microsoft may have render x-plane useless.

 

Only fix I can suggest, and not for all airplane (payware) is to lower resosultion to "low"... all low and you get (if lucky) a constant 30 fps. So plug-in gone... fancy aircraft bought with hard cash.. gone. X-plane is silent. I wish w heard from them -same with payware aircraft sellers. After all, taking your money should have a little bit of "customer service" inclusive of after sale!
commented by (866 points)
Sigh... to bad to see Microsoft imposing so many restrictions. Windows 10 handles too much for the user, which I do not like. I stuck with Windows 7.

5 Answers

+1 vote
answered by (16 points)
Hi,

Same problem here:

I removed all plugins and updated so the installer (beta checked) would fix that

I usually fly with (Airfoillabs C172SP 1.61) but have the same behavior with the the default Cessna 172:

I fly for a while at a regular frame rate (ex: 50 for the default Cessna) then the rate goes down to 2FPS.

Regards,

Philippe
commented by (42 points)
Glad to see i am not alone. yet, an answer or fix would be a good step from X-Plane!
commented by (10 points)
Philippe,  not sure you have answered anything.

Brett
commented by (16 points)
Hi Brett,

As I was posting my issue I noticed the note that said something like "are you sure this problem has not been posted yet ?". So I did look; found a similar issue and thought I could mention that another user had the problem.

My point is that I did not intend to answer anything but rather stress that this issue was occurring elsewhere.

To my credit you'll note that I tested removing all plugins as this could have had an effect ;)

Regards,

Philippe
commented by (10 points)
Sorry Philippe,

I misunderstood your mail since the last sentence in your comment stated the problem and it reads like you are still having it.

Brett
commented by (16 points)
Hi,

 

So this is what I did:

1) uninstalled KB3176938 (I did skip testing just after that unfortunately)

2) Verified I had the latest NVIDIA driver (actually saw a strange error along the way so re-installed the drivers' setup package which told me I was up to date) - I have a GTX980.

3) accepted the latest update for windows - it did re-install KB3176938 (My history says Window 10 Version 1607)

So far I have not noticed the issue anymore.

Regards,

 

Philippe
+1 vote
answered by (42 points)
So this is a known issue. Will x-plane support advise?
commented by (10 points)
Same issue here. But only after the upgrade to RC3. Before that all was fine.
commented by (42 points)
Thanks for adding to this thread. Yet not a word from x-plane gurus?
commented by (42 points)
nothing... not a word!
commented by (866 points)

That is because this "lag" is NOT an X-Plane issue. It is an issue with the recent Windows 10 KB3176938 update. 

0 votes
answered by (17 points)
Same here.

GTX980 - i7 4790k 4Ghz - 32GB RAM - Win10 - bla bla...

I used to have normal 35-40 fps with a good level of detail and plenty of plugins.

After 10.50 update it drops to 2pfs maximum. All plugins and scenery packs disabled.
commented by (42 points)

worked with NVDIA online chat support, they provided the following. Tried it and it did not help much.. i get best frame for a while (longer) with x-plane rendering Preset to low...

i share below the detail of the conversation if anyone can use.. and have more luck than me. Note: to date- silence from x-plane support. No one has even responded to my queries.

Abrar: Hi, my name is Abrar. How may I help you? Denis Meuret: hello
Denis Meuret: i need help to set up the GForce 960 control panel for x-plane
Denis Meuret: can you assist in advising of the best setting for this? Denis Meuret: when i go to control panel NVIDIA control panel... Denis Meuret: i go to Manage 3D setting
Denis Meuret: then Tab Program Settings
Denis Meuret: correct? Abrar: I'd be happy to help,
Abrar: make the following changes: Go to NVIDIA control panel->Manage  3d settings->Power  management mode, If it
is set to adaptive please select “Prefer maximum performance”.
Abrar: • Ambient Occlusion – Off
• Triple buffering – off
• Threaded optimization - ON
• Vertical Sync – Adaptive
Denis Meuret: Go to NVIDIA control panel->Manage  3d setting.. ok so far
Denis Meuret: do i look in GLOBAL SETTINGS or Program Settings... Denis Meuret: i have 2 monitors
Abrar: make these changes in global settings itself
Denis Meuret: ok.. it was set as such..
Abrar: ok, thats all the changes you need to make
Denis Meuret: for some unknown reason, X-Plane 10 drop the fps from 30 to 5 after playing it for a bit... most time drop frame occurs when i navigate out of game on one screen and gor to 2nd screen...
Denis Meuret: what about the program setting tab? Denis Meuret: 1.Select a program to customize?
Denis Meuret: anything there i can adjust for better performance?
Abrar: no
Denis Meuret: ok... what was the purpose of this tab if not to be used?
Denis Meuret: well.. no changes... i started this chat with X-Plane 10 running at 35 fps... and now dropped to 5fps without even playing or interacting with x-plane
Abrar: FPS will fluctuate depending on the graphics on game , have you tested with other games ? Denis Meuret: yup... same issue
Denis Meuret: start well.. and if i navigate to 2nd screen to do anything fps drop and never recover
Denis Meuret: i have latest driver...
Denis Meuret: de-installed it.. reinstall fresh
Denis Meuret: nothing changed
Denis Meuret: this is my processor
Denis Meuret: 3.60 gigahertz Intel Core i7-4790
256 kilobyte primary memory cache
1024 kilobyte secondary memory cache
8192 kilobyte tertiary memory cache
64-bit ready
Multi-core (4 total) Hyper-threaded (8 total)

Denis Meuret: 16324 Megabytes Usable Installed Memory

Slot 'ChannelA-DIMM0' has 8192 MB (serial number
A905A2C9)
Slot 'ChannelB-DIMM0' has 8192 MB (serial number
3970F294)

Abrar: , please perform the following steps to send us the “msinfo32” (system configuration) file.

1) Press Windows key + R .

2) In this field, type in "msinfo32" and then press ENTER on your keyboard

3) This will bring up the Microsoft System Information utility. With your mouse, left-click over the top menu bar and select
"File" and then choose "Save".

0 votes
answered by (19.3k points)

If you have the Windows 10 anniversary update and are experiencing FPS problems:

  1. Open Xbox app
  2. Sign in with your Microsoft account
  3. Click on the settings "gear" icon at the bottom of the left-hand sidebar.
  4. Click the Game DVR tab.
  5. Toggle "Take screenshots using Game DVR" to off.

Please see this knowledge base article for more information.

commented by (42 points)
Excellent answer.. just a slight problem, we are talking about X-Plane and not Xbox....
commented by (19.3k points)
Yes, I said the XBox app on purpose. Microsoft has changed settings that are easiest to fix by using the Xbox app. If you don't want to use those steps, the article also lists a way to manually change settings in Registry Edit, but you do so at your own risk.
commented by (42 points)
edited by
Right on point. While we get some "wild" suggestions on how to fix the un-fixable, X-Plane support is silent. Spend your $$, buy plug-ins and goodies, but for God sake, never need a fix. I have the advantage to have microsoft support available through my business, and there are unable to advise as this issue seems to be inherent to x-plane and their issue in keeping up with advancing upgrade of Window 10. It is a simple matter of "keeping up" with window upgrade, understandably not the problem of window 10 - x-plane not being a major software critical application. So... x-plane is working at best with lowest settings. Avoid any activity outside x-plane (window search, Internet browsing), disable all paid plug-ins. If you do so, you run a chance with 16 gigs of Ram, a Nvidia graffic card and advance CPU, to get about 12fps. One day, x-plane 10.5x version will catch up with window. Until that day, the charismatic founder of x-plane does not care, and your are left dry of any support.
asked Oct 5, 2016 by (42 points)
0 votes
Re- Xbox fix for X-plane
commented by (866 points)
@Airmac101 and @ericlonnett

--> Please stop accusing X-Plane support of "doing nothing". They have already suggested multiple solutions. Anything beyond that (like the lack of the ability to delete updates from Windows 10 after 10 days), is MICROSOFT's problem, not Laminar Research's.

Airmac101, Of COURSE Microsoft will point the fingers at X-Plane. What makes you think they will do otherwise? Some support person in India being asked about a flight simulator he probably never heard of... and you expect them to admit that Microsoft is in the wrong? Of course not!

Take a look at this thread:

https://obsproject.com/forum/threads/severe-lag-issues-since-windows-update.55156/

 

This "lag" issue is Window's problem, not X-Plane's, not Laminar Research's. You can't merely "update" the simulator to work with an obviously faulted Windows update. Please stop saying Laminar Research is "hanging you out to dry" or "keeping silent". I assure you it is not intentional. There is only so much they are actually capable of fixing; this may be one of those things out of there power. You can continue to complain about it, or investigate for new solutions. Pointing fingers at X-Plane support will not get you anywhere.
commented by (42 points)
" Please stop accusing X-Plane support of "doing nothing". They have already suggested multiple solutions." and "Some support person in India being asked about a flight simulator he probably never heard of... "

So a couple of correction here. i have spent a lot of time on the phone with X-Plane, and yes, they cannot do anything for version 10.5x. Version 11 may fix this, but right now X-plane developer have no focus on this issue.

Microsoft. You may reach India if you call. By mean of my profession and role, i deal with Microsoft USA - software developer and architect on a daily basis. I am not sure of India, but i can tell you that issue can be mitigate between X-plane and Microsoft. Right now, neither see value in it and no fix will occur.

Removing update- Microsoft - is not always possible. Once updated, the update is difficult if not impossible to remove.

 

so until X-plane version 11, i hold back my resolution, tweak my data ref.. and manage. but Pointing fingers is how you get people to get off their lazy excuses and do something.... all due respect.
commented by (42 points)
"I really have better things to do than read about your lectures online. Of COURSE I stepped outside of the chain of command somewhere, and saw this coming....

It seems that the issue (and I posted it on many of these threads) was resolved by updating the driver version. It doesn't matter to me who is at fault - and that's not the point, but it's just very frustrating when the finger is just pointed in any direction other than theirs (whoever that is, and I don't care)."

 

Driver update does not fix for all... i found a small plugin that seems to assist in bettering the fps, not solve it, but assist in increasing fps... it is a script you can add to FlyWithLua called Auto_LOD 1.3.lua. I managed some settings through this and get "workable" fps around 12 to 18 fps when experiencing a drop to 5 or 6fps.
commented by (32 points)
I don't have any plug-ins running right now, so that seemed to resolve my issue. I just figured I would wait till 11 to deal with all the re-configuration, etc. I guess it's overall a catch22. Xplane has to shift focus at some point to 11. I realize that it makes sense that they would have a stable 10 before they did so, but maybe it's just cause the environments change so much today, that this is just not really feasable (driver versions, software versions always rapidly changing).
commented by (866 points)
@Airmac101

Perhaps I was a bit harsh, but my main point of conveyance was that you were suggesting in earlier comments that LR was not doing anything. Now, I am not affiliated with LR or Windows, so I stand as an outsider when I was saying that there are restrictions imposed on the Windows 10 OS that are bothersome to the more advanced user.

And my comment was most originally enticed because in some of your earlier comments I thought I sensed some sarcasm:

--

"Thanks for adding to this thread. Yet not a word from x-plane gurus?

nothing... not a word!"

--

One can say I got a little defensive lol. :-)
0 votes
answered by (32 points)
I think updating to the newly available driver and geforce experience will fix this issue. I was able to run a whole flight at high settings sucessfully, which I was never able to do since the windows update / 10.50 confusion. I hope this helps! Thanks

Welcome to X-Plane Q&A, where you can ask support questions and get answers from members of the community.

This site is for X-Plane support questions only. Please search for existing answers before posting your question. Off-topic questions will be locked.

If you’re new, you’ll need to register before asking your first question.

If your question is answered, click on the check mark to select the best response.

Categories

...