This site is being deprecated.

Please see the official X‑Plane Support page for help.

+3 votes
asked by (24 points)
I have the Saitek Cessna Yoke and Rudder and they both seem to be working fine in XP11. I've calibrated them and all of the axes seem to be recognized correctly. When I taxi and on the takeoff roll out I can use the rudder pedals to steer the nose. But when I am in the air and turn it seems as though the auto-rudder is engaged because if I use any rudder at all my turns become completely uncoordinated. Even in a 45 degree turn it is perfectly coordinated if I don't use any rudder. I see in the manual that XP11 will automatically engage the auto-rudder if it doesn't detect rudder pedals but it sees mine.

So is there a way to turn this off manually or is there something that I am doing wrong?
commented by (15 points)
Ah yes. The auto-rudder is definitely activated for me too, and no apparent way to fix it...
commented by (15 points)
I hate to do this, but DITTO, "me too".  XP11 R1.05 (but this problem has been around for me since XP11 beta).  Flying default Cessna with Saitek Cessna Rudder pedals (properly calibrated).  Saitek Proflight Yoke System too.  What gives?  XP11 is supposed to be all about flight model accuracy.  This is NOT realistic!
commented by (11 points)

Please look into this Laminar Research. I have just "converted" from FSX to X-Plane 11 because it's supposed to be the most realistic flight sim with physics engine calculating actual lift/drag etc. but I'm left with a pretty bland experience when I'm flying with rudder pedals (Saitek Pro Flight Rudder Pedals recognized by XP11 and perfectly calibrated and all sliders far left for max realism) only to discover that XP11 is applying auto rudder for me as soon as I take off, so no matter my turn rates the "ball" never leaves its center position despite no use of rudder. If I perform a "realistic" turn with use of rudder I'm just destabilizing the turn instead.

Clearly the auto-rudder is interfering with the controls when it is supposed to be disabled as I have rudder pedals attached, recognized and calibrated correctly.

commented by (18 points)
For those of you who observed like me autocoordination during turns even with a yaw axis assigned to a rudder or a joystick that is supposed to deactivate the autocoordination feature according LR:  the bug is coming from the stability augmentation that is currently working the other way around.  It has to be set at 100% which is giving no aids (this is why it is a big because no aid corresponds to 0%)
commented by (24 points)
If they is the case then it would have been nice to hear from the support person that blew me off over the course of several emails back and forth with him.

Anyway, I tried this and don't notice any change. A full aileron deflection bank change from 30 deg left to 30 deg right, without touching the rudder pedals, barely made the ball go past the center. Looking at the control deflection data output also shows that during this type of maneuver the software isn't seeing the rudder deflecting either. It only shows a noticeable change in deflection when I actually am pushing on the rudder pedals. ARGH!


Though when I go to the control profile from the main menu it says that I have the augmentation set at 100% but when I go to the menu during a flight it says that the augmentation is 0% (always) and I can't change it. I don't know what that means but it's another frustration inducer.


Maybe I should just try P3D or go back to FSX, this is stupid and the lack of support from Laminar Research is disappointing.

3 Answers

+1 vote
answered by (20 points)
That explains a lot.. all the learn to fly books I've been reading talk about coordinated turns but in xp10/11 it seamed that the ball on the turn coordinator went all out of wack if I touched the rutter pedels in a turn. But like you said if you don't use the rutter, your turn was perfectly coordinated. I also use the saitek yoke and rudder petals.

A solution on this would be great.
0 votes
answered by (18 points)
Same here...apparently this is not new.  I ve read the same issue reported on a forum but with xplane 10!
0 votes
answered by (14 points)

This was the worst part of Xplane for me but I have some good news.  It's been solved!  You have to use Planemaker and make a custom version of your plane.  There' a setting in PM called "Rudder tied to aileron" that you can set to a negative number (I use -0.8).  This makes the slip ball deflect all the way in turns like you'd expect it to.

Just edit that value and save the plane

More info here